hdu 1533 Going Home (费用流)



On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 
 
You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
Input
There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M. 
Output
For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay. 
Sample Input
2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0
Sample Output
2
10
28


  1. 题意就是同等个数的m和H,让每个m走到H里,每步花费1,求最小的花费  
  2. //首先预处理图,分离出m和H,然后从超级源点向每个m连边,容量1,花费0,从每个H向超级汇点连边,容量1,花费0,从每个m向每个H连边,容量1,花费为它们之间的步数,然后套模板求出最小费用流即是答案  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int N = 1e3+10;
const int inf = 0x3f3f3f3f;
typedef pair<int,int>P;
char str[N];
struct node
{
    int x, y;
}v1[N], v2[N];

struct edge
{
    int to, cap, cost, rev;
};
vector<edge>p[N];
void add(int u,int v,int cap,int w)
{
    edge e;
    e.to=v, e.cap=cap, e.cost=w, e.rev=p[v].size();
    p[u].push_back(e);
    e.to=u, e.cap=0, e.cost=-w, e.rev=p[u].size()-1;
    p[v].push_back(e);
    return ;
}

int d[N], h[N], prev1[N], pree[N];

int min_cost_flow(int s,int t,int f)
{
    int res=0;
    memset(h,0,sizeof(h));
    while(f>0)
    {
        fill(d,d+t+1,inf);
        priority_queue< P, vector<P>, greater<P> >q;
        q.push(P(0,s));
        d[s]=0;
        while(!q.empty())
        {
            P x=q.top();q.pop();
            int w=x.first, u=x.second;
            if(d[u]<w) continue;
            for(int i=0;i<p[u].size();i++)
            {
                int v=p[u][i].to;
                w=p[u][i].cost;
                if(p[u][i].cap>0&&d[v]>d[u]+w+h[u]-h[v])
                {
                    d[v]=d[u]+w+h[u]-h[v];
                    prev1[v]=u, pree[v]=i;
                    q.push(P(d[v],v));
                }
            }
        }
        if(d[t]==inf) return -1;
        for(int i=0;i<=t;i++) h[i]+=d[i];
        int flow=f;
        for(int i=t;i!=s;i=prev1[i])
        {
            flow=min(flow,p[prev1[i]][pree[i]].cap);
        }
        f-=flow, res+=(h[t]*flow);
        for(int i=t;i!=s;i=prev1[i])
        {
            edge &e=p[prev1[i]][pree[i]];
            e.cap-=flow;
            p[e.to][e.rev].cap+=flow;
        }
    }
    return res;
}

int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m),m||n)
    {
        int cnt1=0, cnt2=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",str);
            for(int j=0;j<m;j++)
            {
                if(str[j]=='m') v1[cnt1].x=i+1, v1[cnt1++].y=j+1;
                else if(str[j]=='H') v2[cnt2].x=i+1, v2[cnt2++].y=j+1;
            }
        }
        int s=2*cnt1, t=s+1;
        for(int i=0;i<cnt1;i++)
        {
            add(s,i,1,0);
            for(int j=0;j<cnt2;j++)
            {
                int w=abs(v1[i].x-v2[j].x)+abs(v1[i].y-v2[j].y);
                add(i,cnt1+j,1,w);
            }
        }
        for(int i=0;i<cnt2;i++) add(i+cnt1,t,1,0);
        int x=min_cost_flow(s, t,cnt1);
        printf("%d\n",x);
        for(int i=0;i<=t;i++) p[i].clear();
    }
    return 0;
}


最近写代码老师把变量名写错,。。。每次都调了很长时间,第一遍写的时候一定要用心,看清。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值