POJ 3162 Walking Race (单调队列)@

flymouse’s sister wc is very capable at sports and her favorite event is walking race. Chasing after the championship in an important competition, she comes to a training center to attend a training course. The center has N check-points numbered 1 through N. Some pairs of check-points are directly connected by two-way paths. The check-points and the paths form exactly a tree-like structure. The course lasts Ndays. On the i-th day, wc picks check-point i as the starting point and chooses another check-point as the finishing point and walks along the only simple path between the two points for the day’s training. Her choice of finishing point will make it that the resulting path will be the longest among those of all possible choices.

After every day’s training, flymouse will do a physical examination from which data will obtained and analyzed to help wc’s future training be better instructed. In order to make the results reliable, flymouse is not using data all from N days for analysis. flymouse’s model for analysis requires data from a series of consecutive days during which the difference between the longest and the shortest distances wc walks cannot exceed a bound M. The longer the series is, the more accurate the results are. flymouse wants to know the number of days in such a longest series. Can you do the job for him?

Input

The input contains a single test case. The test case starts with a line containing the integers N (N ≤ 106) and M (M < 109). Then follow N − 1 lines, each containing two integers fi and di (i = 1, 2, …, N − 1), meaning the check-points i + 1 and fiare connected by a path of length di.

Output

Output one line with only the desired number of days in the longest series.

Sample Input
3 2
1 1
1 3
Sample Output
3
Hint

Explanation for the sample:

There are three check-points. Two paths of lengths 1 and 3 connect check-points 2 and 3 to check-point 1. The three paths along with wc walks are 1-3, 2-1-3 and 3-1-2. And their lengths are 3, 4 and 4. Therefore data from all three days can be used for analysis.



给定一颗树,求每个节点的最长路径,并求一个最长区间,这个区间的最大最小值差不超过m;

解:单调队列,类似于迟取法;


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
typedef long long LL;
const int N = 2e6+10;
const int mod = 1e9+7;
int head[N], cnt, dis[N], dis1[N], dis2[N];
struct node
{
    int to, w, next;
}p[N];

void init()
{
    memset(head,-1,sizeof(head));
    cnt=0;
}

void add(int x,int y,int z)
{
    p[cnt].to=y, p[cnt].w=z, p[cnt].next=head[x],head[x]=cnt++;
    return ;
}

int pos, ans, n, m;
int vis[N];
struct Q
{
    int u, v;
};

void bfs(int x,int *s)
{
    memset(vis,0,sizeof(vis));
    s[x]=0, ans=0, vis[x]=1;
    queue<Q>q;
    Q tmp;
    tmp.u=x, tmp.v=0;
    q.push(tmp);
    while(!q.empty())
    {
        tmp=q.front();q.pop();
        int u=tmp.u, w=tmp.v;
        for(int i=head[u];i!=-1;i=p[i].next)
        {
            int v=p[i].to;
            if(vis[v]) continue;
            vis[v]=1;
            s[v]=w+p[i].w;
            if(s[v]>ans) ans=s[v], pos=v;
            tmp.u=v, tmp.v=s[v];
            q.push(tmp);
        }
    }
    return ;
}
int xmin[N], xmax[N];
int solve()
{
    int s1=0, s2=0, t1=0, t2=0,i,  j=1;
    ans=0;
    for(i=1;i<=n;i++)
    {
        while(s1<t1&&dis[xmin[t1-1]]>=dis[i]) t1--;
        while(s2<t2&&dis[xmax[t2-1]]<=dis[i]) t2--;
        xmin[t1++]=i, xmax[t2++]=i;
        if(dis[xmax[s2]]-dis[xmin[s1]]>m)
        {
            ans=max(ans,i-j);
            while(dis[xmax[s2]]-dis[xmin[s1]]>m)
            {
                j=min(xmax[s2],xmin[s1])+1;
                while(s1<t1&&xmin[s1]<j) s1++;
                while(s2<t2&&xmax[s2]<j) s2++;
            }
        }

    }
    ans=max(ans,i-j);
    return ans;
}

int main()
{
    int  x, w;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        init();
        for(int i=1; i<n; i++)
        {
            scanf("%d %d", &x, &w);
            add(i+1,x, w);
            add(x,i+1, w);
        }
        bfs(1,dis);
        bfs(pos,dis1);
        bfs(pos,dis2);
        for(int i=1; i<=n; i++)
        {
            dis[i]=max(dis1[i], dis2[i]);
        }
        printf("%d\n",solve());
    }
    return 0;
}
























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值