poj 3349 Snowflake Snow Snowflakes (哈希)@

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.

在n (n<100000)个雪花中判断是否存在两片完全相同的雪花,每片雪花有6个角,每个角的长度限制为1000000

两片雪花相等的条件:雪花6个角的长度按顺序相等(这个顺序即可以是顺时针的也可以是逆时针的)

解:首先找到当前序列的字典序最小序列,作为唯一标示,然后存入哈希表中

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 1e6+10;
const int mod = N;
int num[N], hash1[N], p[N][7],next1[N], cnt;
int getnum(int k)
{
    int sum=0;
    for(int i=0;i<6;i++) sum=(sum%mod+p[k][i]%mod)%mod;
    return sum;
}

int judge(int k)
{
    int r=getnum(k);
    for(int i=hash1[r];i!=-1;i=next1[i])
    {
        for(int j=0;j<6;j++)
        {
            if(p[k][j]!=p[i][j]) break;
            if(j==5) return 1;
        }
    }
    next1[cnt]=hash1[r];
    hash1[r]=cnt++;
    return 0;
}


int main()
{
    int n;
    scanf("%d", &n);
    memset(hash1,-1,sizeof(hash1));
    int flag=0, h=0;
    cnt=0;
    while(n--)
    {
        for(int i=0; i<6; i++)   scanf("%d", &num[i]);
        if(flag) continue;
        int k1=0, k2=0;
        for(int i=1; i<6; i++)
        {
            for(int j=0; j<6; j++)
            {
                if(num[(k1+j)%6]>num[(i+j)%6])
                {
                    k1=i;
                    break;
                }
                else if(num[(k1+j)%6]<num[(i+j)%6]) break;
            }
        }
        for(int i=1; i<6; i++)
        {
            for(int j=0; j<6; j++)
            {
                if(num[(k2-j+6)%6]>num[(i-j+6)%6])
                {
                    k2=i;
                    break;
                }
                else if(num[(k2-j+6)%6]<num[(i-j+6)%6]) break;
            }
        }
        int k=1, u=k1;
        for(int i=0; i<6; i++)
        {
            if(num[(k1+i)%6]>num[(k2-i+6)%6])
            {
                k=-1, u=k2;
                break;
            }
            if(num[(k1+i)%6]<num[(k2-i+6)%6]) break;
        }
        for(int i=0;i<6;i++)    p[h][i]=num[(u+k*i+6)%6];
        if(judge(h)) flag=1;
        h++;
    }
    if(flag) printf("Twin snowflakes found.\n");
    else printf("No two snowflakes are alike.\n");
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值