poj 2513 Colored Sticks (无向欧拉路+字典树)

You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a straight line such that the colors of the endpoints that touch are of the same color?
Input
Input is a sequence of lines, each line contains two words, separated by spaces, giving the colors of the endpoints of one stick. A word is a sequence of lowercase letters no longer than 10 characters. There is no more than 250000 sticks.
Output
If the sticks can be aligned in the desired way, output a single line saying Possible, otherwise output Impossible.
Sample Input
blue red
red violet
cyan blue
blue magenta
magenta cyan
Sample Output
Possible
Hint
Huge input,scanf is recommended.

给出m对数 判断是否构成欧拉路(所有边当且仅遍历一遍),当奇数度数大于2时不成立;成立条件:一条直线,或者环,或者直线加环;

有向为(有一个入度-出度=1,出度-入度=1);

用map(内部排序)标记超时,poj不支持unordered_map,所以用字典树优化

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#include <string>
using namespace std;
const int N = 500000+5;
char s1[30], s2[30];
int degree[N], f[N];
struct node
{
    int id;
    node *next2[30];
    node(){
        id=0;
        for(int i=0;i<26;i++)
            next2[i]=NULL;
    }
};
node *root;
int k;
int getid(char *s)
{
    int len=strlen(s);
    node *p=root;
    node *tmp=NULL;
    for(int i=0;i<len;i++)
    {
        if(!p->next2[s[i]-'a'])
        {
            tmp=new node;
            p->next2[s[i]-'a']=tmp;
        }
        p=p->next2[s[i]-'a'];
    }
    if(p->id==0) p->id=++k;
    return p->id;
}
int getf(int x)
{
    if(x!=f[x]) f[x]=getf(f[x]);
    return f[x];
}

void unio(int x,int y)
{
    int t1=getf(x), t2=getf(y);
    if(t1!=t2) f[t1]=t2;
    return ;
}

int main()
{
    k=0;
    root=new node;
    for(int i=0; i<N; i++) f[i]=i;
    while(scanf("%s %s", s1, s2)!=EOF)
    {
        int id1=getid(s1), id2=getid(s2);
        degree[id1]++,degree[id2]++;
        unio(id1,id2);
    }
    int s=getf(1),num=0;
    for(int i=1; i<k; i++)
    {
        if(num>2)
        {
            puts("Impossible");
            return 0;
        }
        if(getf(i)!=s)
        {
            puts("Impossible");
            return 0;
        }
        if(degree[i]%2==1) num++;
    }
    if(num>2) puts("Impossible");
    else puts("Possible");
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值