AtCoder - 2286 Factors of Factorial(数学思维)

本文介绍了一种计算给定整数N的阶乘(N!)正因子数量的方法,并提供了一个C++实现示例。通过将N!分解为其质因数的形式,可以有效地计算出因子的数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Statement

You are given an integer N. Find the number of the positive divisors of N!, modulo109+7.

Constraints

  • 1N103
Input

The input is given from Standard Input in the following format:

N
Output

Print the number of the positive divisors of N!, modulo 109+7.

Sample Input 1

3
Sample Output 1

4

There are four divisors of 3! =6123 and 6. Thus, the output should be 4.

Sample Input 2

6
Sample Output 2

30
Sample Input 3

1000
Sample Output 3

972926972

求一个数的阶乘的因子有多少个,为了去重,可以将这个数表示成素因子的乘积

将 N 分解质因子后得到这样的格式:N = 2^a \times 3^b \times 5^c \times 7^d \times ...N=2a×3b×5c×7d×...
那么约数个数为(a + 1) \times (b + 1) \times (c + 1) \times ...(a+1)×(b+1)×(c+1)×...
因为对于每一个素因子,比如 2,我们可以选择 0~a 个,根据乘法原理,就得到了上面的式子



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
const int N = 1e5+10;
typedef long long LL;
const LL mod = 1e9+7;
int a[N];

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=2;i<=n;i++)
        {
            int x=i;
            for(int j=2;j<=x;j++)
            {
                while(x%j==0)
                {
                    a[j]++;
                    x/=j;
                }
            }
            if(x!=1) a[x]++;
        }
        LL ans=1;
        for(int i=1;i<=n;i++)
        {
            if(a[i]!=0) ans=(ans*(a[i]+1))%mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值