Xor Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)Total Submission(s): 2831 Accepted Submission(s): 1223
Problem Description
Zeus 和 Prometheus 做了一个游戏,Prometheus 给 Zeus 一个集合,集合中包含了N个正整数,随后 Prometheus 将向 Zeus 发起M次询问,每次询问中包含一个正整数 S ,之后 Zeus 需要在集合当中找出一个正整数 K ,使得 K 与 S 的异或结果最大。Prometheus 为了让 Zeus 看到人类的伟大,随即同意 Zeus 可以向人类求助。你能证明人类的智慧么?
Input
输入包含若干组测试数据,每组测试数据包含若干行。
输入的第一行是一个整数T(T < 10),表示共有T组数据。
每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。
输入的第一行是一个整数T(T < 10),表示共有T组数据。
每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。
Output
对于每组数据,首先需要输出单独一行”Case #?:”,其中问号处应填入当前的数据组数,组数从1开始计算。
对于每个询问,输出一个正整数K,使得K与S异或值最大。
对于每个询问,输出一个正整数K,使得K与S异或值最大。
Sample Input
2 3 2 3 4 5 1 5 4 1 4 6 5 6 3
Sample Output
Case #1: 4 3 Case #2: 4
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<map>
#include <set>
#include <bits/stdc++.h>
using namespace std;
const int N = 1e5+10;
typedef long long LL;
int rt[N*32][2], sum[N*32], cnt;
LL bit[34];
void insert1(LL x)
{
int root=0;
for(LL i=32;i>=0;i--)
{
int v=((x&bit[i])?1:0);
if(rt[root][v]==-1)
{
rt[root][v]=cnt;
rt[cnt][0]=rt[cnt][1]=-1;
cnt++;
}
root=rt[root][v];
}
return ;
}
LL ans;
void get(LL x)
{
int root=0;
for(LL i=32;i>=0;i--)
{
int v=((x&bit[i])?1:0);
if(rt[root][1^v]!=-1)
{
if((1^v)==1) ans|=(1<<i);
root=rt[root][1^v];
}
else
{
if(v==1) ans|=(1<<i);
root=rt[root][v];
}
}
return ;
}
int main()
{
int t, ncase=1;
scanf("%d", &t);
bit[0]=1;
for(int i=1;i<=32;i++) bit[i]=bit[i-1]*2;
while(t--)
{
int n, m;
scanf("%d %d", &n, &m);
rt[0][1]=rt[0][0]=-1;
cnt=1;
for(int i=0;i<n;i++)
{
LL x;
scanf("%lld", &x);
insert1(x);
}
printf("Case #%d:\n",ncase++);
while(m--)
{
LL x;
scanf("%lld", &x);
ans=0;
get(x);
printf("%lld\n",ans);
}
}
return 0;
}