hdu 6000 Wash(优先队列)



Wash

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 64000/64000 K (Java/Others)
Total Submission(s): 1012    Accepted Submission(s): 260


Problem Description
Mr.Panda is about to engage in his favourite activity doing laundry! He’s brought L indistinguishable loads of laundry to his local laundromat, which has N washing machines and M dryers.The  ith  washing machine takes  Wi  minutes to wash one load of laundry, and the  ith  dryer takes Di minutes to dry a load of laundry.
At any point in time, each machine may only be processing at most one load of laundry.
As one might expect, Panda wants to wash and then dry each of his L loads of laundry. Each load of laundry will go through the following steps in order:
1. A non-negative amount of time after Panda arrives at the laundromat, Panda places the load in an unoccupied washing machine i.
2. Wi minutes later, he removes the load from the washing machine, placing it in a temporary holding basket (which has unlimited space)
3. A non-negative amount of time later, he places the load in an unoccupied dryer j 
4. Dj minutes later, he removes the load from the dryer Panda can instantaneously add laundry to or remove laundry from a machine. Help Panda minimize the amount of time (in minutes after he arrives at the laundromat) after which he can be done washing and drying all L loads of laundry!
 

Input
The first line of the input gives the number of test cases, T.
T test cases follow. Each test case consists of three lines. The first line contains three integer L, N, and M.
The second line contains N integers  W1,W2,...,WN  representing the wash time of each wash machine.
The third line contains M integers  D1,D2,...,DM  representing the dry time of each dryer.
 

Output
For each test case, output one line containing “Case #x: y”, where x is the test case number (starting from 1) and y is the minimum time it will take Panda to finish his laundry.

limits


1T100 .
1L106 .
1N,M105 .
1Wi,Di109 .
 

Sample Input
  
  
2 1 1 1 1200 34 2 3 2 100 10 1 10 10
 

Sample Output
  
  
Case #1: 1234 Case #2: 12


题意:有L件衣服,有n 个洗衣机,m 个烘干机,告诉你每个洗衣机的洗衣服的时间,和每个烘干机的烘干时间, 每个机器 、一个时间段只能处理一件衣服,问洗完这L件衣服最短时间是多少

解:首先预处理出每件衣服的最早洗完时间,最后完成任务的时间就是  每一件衣服开始洗的时间点加上洗和烘干所用时间的最大值 那么贪心的将最晚的洗完衣服的时间点加上

所用时间最小的烘干时间 尽可能剪短最晚时间

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
#include <bits/stdc++.h>
using namespace std;
const int N =1e6+10;
typedef long long LL;
struct node
{
    LL x, y;
    bool operator <(const node &A)const
    {
        return x>A.x;
    }
};
priority_queue<node>p,q;
LL a[N];

int main()
{
    int t, ncase=1;
    scanf("%d", &t);
    while(t--)
    {
        int l, m, n;
        scanf("%d %d %d",&l, &n, &m);
        while(!p.empty()) p.pop();
        while(!q.empty()) q.pop();
        node tmp;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d", &tmp.x);
            tmp.y=tmp.x;
            q.push(tmp);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%I64d", &tmp.x);
            tmp.y=tmp.x;
            p.push(tmp);
        }
        for(int i=0;i<l;i++)
        {
            tmp=q.top();q.pop();
            a[i]=tmp.x;
            tmp.x+=tmp.y;
            q.push(tmp);
        }

        LL ans=0;
        for(int i=l-1;i>=0;i--)
        {
            tmp=p.top();p.pop();
            ans=max(ans,a[i]+tmp.x);
            tmp.x+=tmp.y;
            p.push(tmp);
        }
        printf("Case #%d: %I64d\n",ncase++, ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值