2017 ccpc 秦皇岛 M(几何)

Safest Buildings

Time Limit: 1 Second       Memory Limit: 65536 KB

PUBG is a multiplayer online battle royale video game. In the game, up to one hundred players parachute onto an island and scavenge for weapons and equipment to kill others while avoiding getting killed themselves. BaoBao is a big fan of the game, but this time he is having some trouble selecting the safest building.

There are  buildings scattering on the island in the game, and we consider these buildings as points on a two-dimensional plane. At the beginning of each round, a circular safe area whose center is located at (0, 0) with radius  will be spawned on the island. After some time, the safe area will shrink down towards a random circle with radius  (). The whole new safe area is entirely contained in the original safe area (may be tangent to the original safe area), and the center of the new safe area is uniformly chosen within the original safe area.

The buildings covered by the new safe area is called the safe buildings. Given the radius of the safe areas and the positions of the buildings, BaoBao wants to find all the buildings with the largest probability to become safe buildings.

Input

There are multiple test cases. The first line of input contains an integer , indicating the number of test cases. For each test case:

The first line contains three integers  (),  and  (), indicating the number of buildings and the radius of two safe circles.

The following  lines each contains 2 integers  and  (), indicating the coordinate of the buildings. Here we assume that the center of the original safe circle is located at , and all the buildings are inside the original circle.

It's guaranteed that the sum of  over all test cases will not exceed 5000.

Output

For each test case output two lines.

The first line contains an integer , indicating the number of buildings with the highest probability to become safe buildings.

The second line contains  integers separated by a space in ascending order, indicating the indices of safest buildings.

Please, DO NOT output extra spaces at the end of each line.

Sample Input
2
3 10 5
3 4
3 5
3 6
3 10 4
-7 -6
4 5
5 4
Sample Output
1
1
2
2 3



题意:
题目说的是一个叫“吃鸡”的游戏。
给出两个半径R,r,R表示第一次的大圈半径,r表示第二次的小圈半径。第一次大圈的圆心位于(0,0),第二次小圈的圆心未知,但在大圈内,给你一个n,然后给出n个屋子的位置,问这些屋子中,第二次在小圈的概率最大的屋子有几个,都是哪些。

解:当R>2*r时 R-2*r 中的点的概率是一样的 这个临界情况是内切 如果圆继续往外移 概率就不是1

        当2*r-R时情况类似

#include <iostream>
#include <cstring>
#include <bits/stdc++.h>
using namespace std;
const int N = 3e5+10;
typedef long long LL;
int a[N];
const double eps = 1e-7;
struct node
{
    double x, y, dist;
    int id;
} p[N];

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, u, R, r, d, maxt;
        scanf("%d %d %d", &n, &R, &r);
        d=R-2*r;
        maxt=-1;
        int k=0;
        for(int i=1; i<=n; i++)
        {
            int x, y;
            scanf("%d %d", &x, &y);
            int dist=x*x+y*y;
            p[i].x=x,p[i].y=y,p[i].dist=dist,p[i].id=i;
            if(dist<=d*d) a[k++]=i;
            if(maxt==-1||dist<=maxt)maxt=dist;
        }
        if(k==0)
        {
            for(int i=1; i<=n; i++)
            {
                if(p[i].dist==maxt) a[k++]=i;
            }
        }
        printf("%d\n",k);
        for(int i=0; i<k; i++)
        {
            printf("%d%c",a[i],i==k-1?'\n':' ');
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值