南阳理工ACM 587 blockhouses

blockhouses

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
输入
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
输出
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
样例输入
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
样例输出
5
1
5
2
4
package acm.ny;

import java.util.Arrays;
import java.util.Scanner;

/**
 * 南阳理工ACM  587  blockhouses
 * @author Alex
 * @Date	20130425
 * @Time	10:33
 * @Result	Accept
 */
public class Ny0587_20130425_0728 {

	private static char [][] grid = null;
	private static boolean [][] isPlaced = null;
	private static int count = 0;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		String [] strs = null;
		int n = 0;
		while(in.hasNextInt()){
			n = in.nextInt();
			count = 0;
			if(n == 0){
				break;
			}else{
				strs = new String[n];
				for(int i = 0; i < n; ++i){
					strs[i] = in.next();
				}
				grid = init(strs);
				isPlaced = new boolean[grid.length][grid[0].length];
				solve(grid, isPlaced,0);
				System.out.println(count);
			}
		}
	}
	private static void solve(char [][] grid, boolean[][] isPlaced, int cur){
		int row,col;
		row = cur / grid[0].length;
		if(row == 0){
			col = cur;
		}else{
			col = cur % grid.length;
		}
		if(cur == grid[0].length * grid.length ){
			int temp = getCount(isPlaced);
			count = temp > count ? temp : count;
		}else{
			if(isCanPlaced(row,col,isPlaced)){    //放置
				isPlaced[row][col] = true;
				solve(grid,isPlaced,cur+1);
				isPlaced[row][col] = false;
			}
			solve(grid,isPlaced,cur+1); //不放
		}
	}
	/**
	 * 判断当前点是否可以放置
	 * @param row 行
	 * @param col 列
	 * @param isPlaced 当前状态
	 * @return
	 */
	private static boolean isCanPlaced(int row, int col, boolean[][] isPlaced){
		int up,left;
		up =  row;
		left = col;
		if(grid[row][col] == 'X'){
			return false;
		}
		boolean canPlaced = true;
		while(up > 0){
			if(isPlaced[up][col]){
				canPlaced = false;
				break;
			}
			if(grid[up][col] == 'X'){
				break;
			}
			--up;
		}
		while(left > 0){
			if(isPlaced[row][left]){
				canPlaced = false;
				break;
			}
			if(grid[row][left] == 'X'){
				break;
			}
			--left;
		}
		return canPlaced;
	}
	/**
	 * 得到当前放置的个数
	 * @param isPlaced
	 * @return
	 */
	private static int getCount(boolean [][] isPlaced){
		int count = 0;
		for(int i = 0; i < isPlaced.length; ++i){
			for(int j = 0; j < isPlaced[i].length; ++j){
				if(isPlaced[i][j]){
					++count;
				}
			}
		}
		return count;
	}
	/**
	 * 将输入数据转换为一个字符矩阵,并且外层用 'X' 包裹
	 * @param strs
	 * @return
	 */
	private static char[][] init(String [] strs){
		char [][] grid = null;
		int rows = strs[0].length() + 2;
		int cols = strs.length + 2;
		grid = new char[rows][cols];
		Arrays.fill(grid[0], 'X');
		for(int i = 1; i < grid.length - 1; ++i){
			grid[i][0] = 'X';
			for(int j = 1; j < grid[i].length-1; ++j){
				grid[i][j] = strs[i-1].charAt(j-1);
			}
			grid[i][grid[i].length-1] = 'X';
		}
		Arrays.fill(grid[grid.length-1], 'X');
		return grid;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值