HDU 2473 Junk-Mail Filter(并查集删除节点)

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9673    Accepted Submission(s): 3067


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
题意: 这里有n封邮件,然后有m个已知信息: M x y 表示x和y是同一种邮件 S x 表示已知的x的信息是错误的,意思就是将x从原来的集合中除去,问根据已知的信息可以确定的是有多少封邮件是不相同的。也就是求集合的个数。
思路: 合并当然用到并查集,但是删除操作需要做一些改变,,在这里我们在初始化的时候将f【i】设为i+n,一开始一共有n个不同的集合,
合并操作和原来的并查集没有区别,每次删除的时候需要做一些改变,我们初始一个id为2*n每次删除i 的时候就将f【i】设为id++;
这样的话就将i从原来的集合中间接的删除了,而判断集合的个数的时候就可以看每封邮件的父亲不相同的一共有多少个。
代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 100005
#define M 1000005

using namespace std;

int f[N*2+M];
int vis[N*2+M];
int n,m,id;

void init()
{
	int i,j;
	for(i=0;i<n;i++)
	{
		f[i]=i+n;
	}
	for(i=n;i<n+n+m;i++)
	{
		f[i]=i;
	}
	return ;
}

int getf(int x)
{
	return f[x]==x?x:(f[x]=getf(f[x]));
}

void merge(int x,int y)
{
	int t1=getf(x);
	int t2=getf(y);
	if(t1!=t2){
		f[t2]=t1;
	}
	return ;
}

void del(int x)
{
	f[x]=id++;
	return ;
}

int main()
{
	int i,j,x,y;
	char s[15];
	int cas=0;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		if(n==0&&m==0) break;
		init();
		id=n+n;
		while(m--)
		{
			scanf("%s",s);
			if(s[0]=='M')
			{
				scanf("%d %d",&x,&y);
				merge(x,y);
			}
			else
			{
				scanf("%d",&x);
				del(x);
			}
			/*for(i=0;i<n;i++) printf("%d ", getf(i));
			printf("\n");*/
		}
		int fin=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++)
		{
			int fa=getf(i);
			if(!vis[fa]){
				vis[fa]=1;
				fin++;
			}
		}
		printf("Case #%d: %d\n",++cas,fin);
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值