POJ 2299 Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 64032 Accepted: 23911

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
题意:其实就是给你一个序列,让你求他的逆序对。
思路: 归并排序求逆序对。模板题
 
代码: 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 500005

using namespace std;

int n;
int a[N];
int r[N];
long long fin;

void mergesort(int left,int right)
{
	
	if(left==right) return ;
	int mid=(left+right)>>1;
	mergesort(left,mid);
	mergesort(mid+1,right);
	
	int i,j,k;
	i=left;
	j=mid+1;
	k=left;
	/*
	while(i<=mid&&j<=right)//归并排序 按照从大到小的顺序排序。 
	{
		if(a[i]>a[j]){
			fin+=(long long )(right-j+1);
			r[k++]=a[i++];
			
		}
		else r[k++]=a[j++];
	}*/
	
	while(i<=mid&&j<=right)//归并排序  按照从小到大的顺序排序。 
	{
		if(a[i]>a[j]){
			fin+=(long long)(mid-i+1);
			r[k++]=a[j++];
		}
		else r[k++]=a[i++];
	}
	
	while(i<=mid){
		r[k++]=a[i++];
	}
	
	while(j<=right)
	{
		r[k++]=a[j++];
	}
	
	
	for(i=left;i<=right;i++)
	{
		a[i]=r[i];
	}
	return ;
}

int main()
{
	while(cin>>n)
	{
		if(n==0) break;
		for(int i=1;i<=n;i++) cin>>a[i];
		fin=0;
		mergesort(1,n);
		cout<<fin<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值