1027 Ignatius and the Princess II

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8885    Accepted Submission(s): 5222


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
题意: 给你n个数 你的任务是求出他的第m个全排列 。 不理解第m个 就写写就明白了 ,,,先动最右边的数字。
algorithm中有一个求 全排列的函数。 next_permutation
函数理解 : 博客: http://blog.csdn.net/lishuhuakai/article/details/8006937
代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

#define MAXN 100010

using namespace std;

int n,m;
int s[1010];

int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=0; i<n; i++)
            s[i] = i+1;
        int t=1;
        bool flag=false;
        while(next_permutation(s, s+n))
        {
            if(flag) break;
            t++;
            if(t == m)
            {
                flag = true;
                for(int i=0; i<n; i++)
                {
                    if(i!=0)printf(" ");
                    printf("%d",s[i]);
                }
            }
        }
        printf("\n");
    }
}

但是这个题 用个 dfs 也能过。。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
//注意为什么要用flag标记提前跳出循环。//回溯的原因!! 
/**
主要原因:
1.如果直接return的话就只是跳到上一层,
而flag是在回溯之前就定义好的,
所以当用flag标记直接调回的时候就不会仅仅返回第上一层,而是直接 逐层返回到第一层,然后结束。 
**/ 
using namespace std ;
int n,m,flag;
int a[1002],sum,vis[1002];

void dfs(int k){
    if(flag==1)return;//提前结束 
    if(k==n+1){
        sum++;
        if(sum==m){
            flag=1; 
            for(int i=1;i<n;i++){
                printf("%d ",a[i]);
            } 
            printf("%d\n",a[n]);
            return;//返回上一层 
        }
    }else{
        for(int i=1;i<=n;i++){
            if(!vis[i]){
                vis[i]=1;
                a[k]=i;
                dfs(k+1);
                vis[i]=0;
            }
        }
    }
}


int main(){
    while(~scanf("%d%d",&n,&m)){
        memset(vis, 0, sizeof(vis));
        sum=flag=0;
        dfs(1);    
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值