POJ 3255

Roadblocks
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16464 Accepted: 5805

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers:  N and  R 
Lines 2.. R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length  D (1 ≤  D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node  N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450
题意: 给你n 个点  m 条边  问你从1到n 的次短路。
思路: 我们知道dij求最短路是根据已经有的x个点 去缩短 到未知点的距离, 那么
当缩短未知点的距离可以缩短的时候,也就是dis[v]=dis[u]+w; 那么我们记录下
次短点的距离 也就是没有缩短之前的dis[v];(当做 val )  然后再用val 和
cdis[v]相比 并且要求比 dis[v] 大。。那么我们就可以同时得到dis[] 和 
cdis[] 。

代码: 
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<iostream>
#include<algorithm>
#define N 5005
#define inf 0x3f3f3f3f

using namespace std;

typedef pair<int ,int > P;

struct node
{
	int to;
	int val;
};

vector< node > edge[N];
int dis[N];
int cdis[N];
int n,m;

void dij()
{
	memset(dis,inf,sizeof(dis));
	memset(cdis,inf,sizeof(cdis));
	int u,v,w,val;
	node tmp;
	
	priority_queue<P , vector< P >,greater<P> >que;
	P p;  p.first=1; p.second=0;
	que.push(p);
	
	while(!que.empty())
	{
		p=que.top(); que.pop();
		u=p.first; w=p.second;
		//printf("%d %d \n",u,w);
		if(cdis[u]<w) continue;
		
		for(int i=0;i<edge[u].size();i++)
		{
			v=edge[u][i].to;  val =edge[u][i].val+w;
			if(dis[v]>val)
			{
				swap(dis[v],val);
				que.push(P(v,dis[v]));
			}
			if(cdis[v]>val&&dis[v]<val)
			{
				cdis[v]=val;
				que.push(P(v,val));
			}
		}
		
	}
	/*
	for(int i=1;i<=n;i++) cout<<dis[i]<<" ";
	cout<<endl;
	for(int i=1;i<=n;i++) printf("%d ",cdis[i]);
	printf("\n");*/
	printf("%d\n",cdis[n]);
}

int main()
{
	cin>>n>>m;
	int u,v,w;
	for(int i=1;i<=m;i++)
	{
		scanf("%d %d %d",&u,&v,&w);
		node tmp;
		tmp.to=v;  tmp.val=w;
		edge[u].push_back(tmp);
		tmp.to=u;
		edge[v].push_back(tmp);
	}
	
	dij();
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值