hdu 5512 博弈(数学)

Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2604    Accepted Submission(s): 1760


Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from  1 to  n. However, only two of them (labelled  aand  b, where  1abn) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled  i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled  j and  k respectively, such that  i=j+k or  i=jk. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer  t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer  n (2n20000) and two different integers  a and  b.
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
 
 
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
 
 
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
 

Source

题意: 数字一共是1到 n  n 个数字

  1. 一开始对于已有数字集合,除了a,b(1<=a,b<=n && a≠b),其他数字都是不存在的。 
  2. 对于每次成功的操作,我们是从已有数字集合之中,任选两个不同数x,y,得到z=x-y或者z=x+y,如果z是在[1,n]范围,而且z这个数字当前不存在,那我们就可以得到这个新数z,并把其放入已有数字集合之中。 
  3. Yuwgna先手,Iaka后手,谁无法操作谁就输了。问你最后的winner是谁。 

(不要脸的粘贴一下别人写的题意)

思路: 其实这个算是一个 数学题。 就是相当于  问你  1  到n  中由  a 和 b  延伸出来的数的个数一共是多少个。 那么就可以转化成   1到 n  的n 个数中 有多少数 是gcd(a,b)   的倍数 。 然后就可以得出答案了。

代码: 

#include<bits/stdc++.h>

using namespace std;

int n,a,b;

int main()
{
	int cas;
	int kk=0;
	cin>>cas;
	while(cas--)
	{
		cin>>n>>a>>b;
		int k=__gcd(a,b);
		
		int sum=n/k;
		sum-=2;
		
		printf("Case #%d: ",++kk);
		
		if(sum%2)
		{
			cout<<"Yuwgna"<<endl;
		}
		else cout<<"Iaka"<<endl;
		
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值