poj 2976 (分数规划)

Dropping tests

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17479 Accepted: 6067

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

Stanford Local 2005

题意: 题意很简单,就是使得 你可以删去k个成绩,使得   所有a的和 / 所有b的和最大。  

思路:分数规划: 我们二分答案,然后求出  按 ai-ans*bi 的大小从大到小排序,自然在前的应该首选。 

代码: 

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>

using namespace std;
typedef long long ll;
const double eps=1e-10;
const int N =1e5+5;

struct node
{
	double s,c;
	double jj;
}a[N];

int n,k,up;

bool cmp(node a,node b)
{
	return a.jj>b.jj;
}

bool jud(double hh)
{
	for(int i=1;i<=n;i++){
		a[i].jj=a[i].c-hh*a[i].s;
	}
	sort(a+1,a+n+1,cmp);
	double sum=0;
	for(int i=1;i<=up;i++){
		sum+=a[i].jj;
	}
	if(sum>=0) return 1;
	return 0;
}

int main()
{
	while(scanf("%d %d",&n,&k)!=EOF)
	{
		if(n==0&k==0) break;
	up=n-k;
	double l,r,mid;
	l=0;r=-1;
	for(int i=1;i<=n;i++){
		scanf("%lf",&a[i].c);
		a[i].c*=100;
		r=max(r,a[i].c);
	}
	for(int i=1;i<=n;i++){
		scanf("%lf",&a[i].s);
	}
	
	double ans=l;
	while((r-l)>eps)
	{
		mid=(l+r)/2;
		//cout<<"mid "<<mid<<endl;
		if(jud(mid)){
			ans=mid;
			l=mid;
		}
		else r=mid;
	}
	int tmpans=int(ans+0.5);
	printf("%d\n",tmpans);
    
	}
	return 0;
}

推荐: 牛客多校第五场 A题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值