1013 A strange lift

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
  
  
3


简单题意:
在一个N层高的楼有一个奇怪的电梯,在每一层只能上升或下降一个特定的层数,中间不会停止,在给定的条件下,问能不能到达指定楼层,可以到达的话返回转操作次数,不可以的话返回-1.

解题思路

搜索题,广度搜索

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
struct node
{
 int pos,t;
 friend bool operator<(node a,node b)
 {
  return a.t>b.t;
 }
};
priority_queue<node>s;
int lift[205],vis[205],n;
int dijkstra(int st,int ed)
{
 node temp,temp1;
 int flag=0;
 temp.pos=st,temp.t=0;
 s.push(temp);
 while(!s.empty())
 {
  temp1=temp=s.top(),s.pop();
  vis[temp.pos]=1;
  if(temp.pos==ed)
  {
   flag=1;
   break;
  }
  temp.pos=temp1.pos-lift[temp1.pos];//
  temp.t=temp1.t+1;
  if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
  s.push(temp);
  temp.pos=temp1.pos+lift[temp1.pos];
  temp.t=temp1.t+1;
  if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
  s.push(temp);
 }
 if(flag)
 return temp.t;
 else
 return -1;
}
int main()
{
 int st,ed;
 while(scanf("%d",&n)!=EOF)
 {
  if(n==0)
  break;
  scanf("%d %d",&st,&ed);
  for(int i=1;i<=n;i++)
  scanf("%d",&lift[i]);
  memset(vis,0,sizeof(vis));
  while(!s.empty())
  s.pop();
  printf("%d\n",dijkstra(st,ed));
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值