杭电acm1002


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.<br>Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?<br>
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. <br><br>Input contains multiple test cases. Process to the end of file.<br>
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. <br>
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 
Sample Output
  
  
3.41
(1)大意:
  在一张纸上,有坐标轴,而且散列者很多点, 每一点与墨水用直线连接,使所有的点最后在同一个地方连接起来。求形成这个水墨画的最短长度
(2)思路:

还是生成树问题,用kruskal算法。定义一个结构体数组,比较函数,值寻找函数备用,对树进行初始化,根据kruscle算法的规则,选取两点权值最小的边进行链接,链接的点都设置为已经访问过,然后在数组中继续寻找,直到所有的点都连起来,这包含了贪心的思想,局部最优,所有的两点都是最短的,最后连接成整体,就是总体最短。
(2)感想:
第一次,一次提交就对了,很激动,还又试了好几遍。很简单吧,就是麻烦点,程序很长,但是思路就是一个最小生成树的kruskal算法


(4):

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
const int N=10005;
double leftt[N],rightt[N];
//double value[N];
int father[N],r[N];
struct point{
  int x,y;
  double value;
}aa[10005];
int cmp(const int i,const int j){
 return aa[i].value<aa[j].value;
}
int find(int x){
  if(father[x]!=x)
   father[x]=find(father[x]);
  return father[x];
}
int main(){
  int n;
  while(scanf("%d",&n)!=EOF){
   for(int i=0;i<N;++i){
     father[i]=i;
  r[i]=i;
  aa[i].value=0.0;
   }
   
   for(int i=0;i<n;++i){
     scanf("%lf%lf",&leftt[i],&rightt[i]);
   }
   int k=0;
   for(int i=0;i<n;++i){
    for(int j=0;j<n;++j){
     if(i!=j)
     {aa[k].value=sqrt((leftt[i]-leftt[j])*(leftt[i]-leftt[j])+(rightt[i]-rightt[j])*(rightt[i]-rightt[j]));
       aa[k].x=i;
    aa[k].y=j;
    k++;
     }
    }
   }
   double sum=0;
   for(int i=0;i<k;++i){
     int e=r[i];
  int x=find(aa[e].x);
   int y=find(aa[e].y);
  if(x!=y){
   sum+=aa[e].value;
 
    father[x]=y;
  }
   }
   printf("%.2lf\n",sum);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值