hdu1162 Eddy's picture(Prim算法模板)

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output

3.41

这道题是用一条最短的线连接所有所给的节点,很明显是用到了Prim算法,是Prim算法的模板题。代码如下

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<iomanip>
#define MAX 100000000
using namespace std;
int n;
double map[105][105];
int vis[105];
double mindis[105];
struct S{
	double x,y;
};
double dist(double x1,double y1,double x2,double y2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void prim(int p){
		int i,j,v;
		double sum=0,minn;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++){
			mindis[i]=map[p][i];
		}vis[p]=1;
		for(i=1;i<n;i++){
			minn=MAX;
			for(j=1;j<=n;j++){
				if(!vis[j]&&mindis[j]<minn){
					v=j;
					minn=mindis[j];
				}
			}vis[v]=1;
			sum=sum+minn;
			for(j=1;j<=n;j++){
				if(!vis[j]&&map[v][j]<mindis[j]){
						mindis[j]=map[v][j];	//需要注意此处的条件
				}

			}



		}
		printf("%0.2lf\n",sum);


}
int main(){
		S ss[105];
		int i,j;
		while(scanf("%d",&n)!=EOF){
		for(i=1;i<=n;i++){
				scanf("%lf%lf",&ss[i].x,&ss[i].y);
		}
		for(i=1;i<=n;i++){
			for(j=i;j<=n;j++){
				map[i][j]=map[j][i]=dist(ss[i].x,ss[i].y,ss[j].x,ss[j].y);
			}
		}
		prim(1);
		}
		return 0;
}
prim算法和dijkstra算法有一定的相似之处,dijkstra算法是找出距离最近的节点之后,将这个节点加入集合中,再松弛这个点和在集合之外的点的距离。

Prim算法是用一个mindis【】数组记录集合外的点与集合的最小距离(即每个分散的点到已连接子图的最小距离),每找到一个新的点,就将mindis的值更新一遍,从而能方便的找到下一个mindis最小的节点。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值