Fibonacci(poj3070)

Fibonacci
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5337Accepted: 3726

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

Fibonacci(poj3070).

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875
AC代码
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
#include <vector>
#include <map>
using namespace std;
struct Mat{
   int num[3][3];
};
Mat mult(Mat a,Mat b){
   Mat c;
   for(int i=1;i<=2;i++)
     for(int j=1;j<=2;j++){
        c.num[i][j]=0;
       for(int k=1;k<=2;k++)
         c.num[i][j]=(c.num[i][j]+a.num[i][k]*b.num[k][j])000;
     }
  return c;
}
Mat my_pow(Mat x,int y){
   Mat ans;
   for(int i=1;i<=2;i++)
    for(int j=1;j<=2;j++){
        if(i==j)
           ans.num[i][j]=1;
        else
           ans.num[i][j]=0;
    }
   for(;y;y>>=1){
       if(y&1)
         ans=mult(ans,x);
       x=mult(x,x);
   }
 return ans;
}
int main(){
    int n;
  while(scanf("%d",&n)){
     if(n==-1)
        break;
     Mat A;
     A.num[1][1]=1;
     A.num[1][2]=1;
     A.num[2][1]=1;
     A.num[2][2]=0;
     A=my_pow(A,n);
   printf("%d\n",A.num[1][2]);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值