Humble Numbers(hdu1058)

Humble Numbers

TimeLimit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K(Java/Others)
Total Submission(s): 8304 Accepted Submission(s):3618


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called ahumble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14,15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humblenumbers.

Write a program to find and print the nth element in thissequence

Input
The input consists of one or more test cases. Each test caseconsists of one integer n with 1 <= n<= 5842. Input is terminated by a value of zero (0)for n.

Output
For each test case, print one line saying "The nth humblenumber is number.". Depending on the value of n, the correct suffix"st", "nd", "rd", or "th" for the ordinal number nth has to be usedlike it is shown in the sample output.

Sample Input
1 2 3 4 1112 13 21 22 23 100 1000 5842 0

Sample Output
The 1sthumble number is 1. The 2nd humble number is 2. The 3rd humblenumber is 3. The 4th humble number is 4. The 11th humble number is12. The 12th humble number is 14. The 13th humble number is 15. The21st humble number is 28. The 22nd humble number is 30. The 23rdhumble number is 32. The 100th humble number is 450. The 1000thhumble number is 385875. The 5842nd humble number is2000000000.

Source

#include <iostream>
#include <stdio.h> 
#include <math.h>     
#include <stdio.h>    
#include <stdlib.h>    
#include <string.h>    
#include <algorithm>   
using namespace std;
const int N=5843;
int n,i;
__int64 hum[N];
__int64 min(__int64 a,__int64 b){
    return a<b?a:b;
}
int main(){
    longi1,i2,i3,i4;
   i1=i2=i3=i4=1;
   hum[1]=1;
   for(i=2;i<N;i++){
       hum[i]=min(hum[i1]*2,min(hum[i2]*3,min(hum[i3]*5,hum[i4]*7)));
       if(hum[i]==hum[i1]*2) i1++;
       if(hum[i]==hum[i2]*3) i2++;
       if(hum[i]==hum[i3]*5) i3++;
       if(hum[i]==hum[i4]*7) i4++;
   }//用已经生成的数去乘以因子然后去最小的数生成新的数
   while(scanf("%d",&n)!=EOF&&n){
        if(n==1&&n0!=11)
           printf("The %dst humble number is %I64d.\n",n,hum[n]);
        else if(n==2&&n0!=12)
           printf("The %dnd humble number is %I64d.\n",n,hum[n]);
        else if(n==3&&n0!=13)
           printf("The %drd humble number is %I64d.\n",n,hum[n]);
        else
           printf("The %dth humble number is %I64d.\n",n,hum[n]);
    }
    return0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值