Humble Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24425 Accepted Submission(s): 10707
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
题意:
定义 Humble Numbers为因子中除2,3,5,7外没有别的因子了(当然因子1不包括在这里边),然后给你一个数,让你求出第n个 Humble Numbers是什么。
这个主要是求 Humble Numbers麻烦点,你要一点点的往上乘,因为反正这些数都是只由2 3 5 7相乘而成,你就从头开始往上乘2,3,5,7就行了
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int hum[5845],n;
int a2,a3,a5,a7;
a2=a3=a5=a7=1;
hum[1]=1;
for(int i=2;i<=5842;i++)
{
hum[i]=min(min(hum[a2]*2,hum[a3]*3),min(hum[a5]*5,hum[a7]*7));
if(hum[i]==hum[a2]*2) a2++;
if(hum[i]==hum[a3]*3) a3++;
if(hum[i]==hum[a5]*5) a5++;
if(hum[i]==hum[a7]*7) a7++;
}
while(~scanf("%d",&n)&&n)
{
if(n%10==1&&n%100!=11)
printf("The %dst humble number is %d.\n",n,hum[n]) ;
else if(n%10==2&&n%100!=12)
printf("The %dnd humble number is %d.\n",n,hum[n]) ;
else if(n%10==3&&n%100!=13)
printf("The %drd humble number is %d.\n",n,hum[n]) ;
else
printf("The %dth humble number is %d.\n",n,hum[n]) ;
}
return 0;
}