HDU 2136 Largest prime factor

Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input
Each line will contain one integer n(0 < n < 1000000).

Output
Output the LPF(n).

Sample Input
1
2
3
4
5

Sample Output
0
1
2
1
3

Author
Wiskey

Source
HDU 2007-11 Programming Contest_WarmUp

#include <stdio.h>
using namespace std;

int a[1000000] = {0};
int main()
{
    int count = 1;                  //记录素数的位置
    for(int i = 2; i<1000000; i++)
    {
        if(a[i]==0)
        {
            a[i] = count;
            for(int j = 2; j*i<1000000; j++)
            {
                a[i*j] = count;     //将包含i的数全部赋值为count
            }
            count++;
        }
    }
    int n;
    while(~scanf("%d",&n))
    printf("%d\n",a[n]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值