POJ 2109 Power of Cryptography

Power of Cryptography
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14528 Accepted: 7378

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source

刚开始做这题的时候还是被数据吓懵了,那么大的数据难道用字符串,如果用字符串怎么开方啊,不懂然后就看了一下disscuss ,发现用double就行,我看了看double的数据的存储范围发现确实没有问题,double的存储能力真是强啊
类型          长度 (bit)           有效数字          绝对值范围
float             32                      6~7                  10^(-37) ~ 10^38
double          64                     15~16               10^(-307) ~10^308
long double   128                   18~19                10^(-4931) ~ 10 ^ 4932
需要注意的是这题用同样的代码C++能过G++就过不了
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
    double  n,k,p;
    while(scanf("%lf %lf",&n,&p)!=EOF)
    {
        if(fabs(n-1)<=1e-8)
        {
            printf("%.0lf\n",p);
            continue;
        }
        k=pow(p,1.0/n);
        printf("%.0lf\n",k);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值