DFS:Prime Ring Problem(素数环)

解体心得:
1、一个回溯法,可以参考八皇后问题。
2、题目要求按照字典序输出,其实在按照回溯法得到的答案是很正常的字典序。不用去特意排序。
3、输出有个坑,就是在输出一串的最后不能有空格,不然要PE,很尴尬。

题目:
Problem Description

    A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

这里写图片描述

Note: the number of first circle should always be 1

Input
n (0 < n < 20).


Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.


Sample Input
6
8


Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6 3 8 5 2


Source
Asia 1993 8 5 2


Source
Asia 19 Shanghai (Mainland China) 
#include<stdio.h>
#include<cstring>
int n,num[21],sum,l,sum1;
bool prim[50];
bool bnum[21];
int circle[21];
int z = 1;

void dfs(int sum)
{
    if(sum == n)
    {
        if(!prim[circle[1]+circle[sum]])//判断第一个和最后一个相加是否是素数
            return;
        for(int j=1;j<=n;j++)
        {
            if(j!=n)
                printf("%d ",circle[j]);//最后一个数字后面不可以加空格,不然要PE,很尴尬;
            else
                printf("%d",circle[j]);
        }
        printf("\n");
        return;
    }
    for(int i=2;i<=n;i++)
    {
        if(!bnum[i])
            continue;
        if(prim[i+circle[sum]])
        {
            circle[sum+1] = i;
            bnum[i] = false;
            dfs(sum + 1);
            bnum[i] = true;
        }
    }
    return;
}
int main()
{
    //先把50以内的素数手写出来
    memset(prim,false,sizeof(prim));
    prim[2] = true;
    prim[3] = true;
    prim[5] = true;
    prim[7] = true;
    prim[11] = true;
    prim[13] = true;
    prim[17] = true;
    prim[19] = true;
    prim[23] = true;
    prim[29] = true;
    prim[31] = true;
    prim[37] = true;
    prim[41] = true;
    prim[43] = true;
    prim[47] = true;
    while(scanf("%d",&n)!=EOF)
    {
        //特判几个很大但是没有任何结果的数,直接输出,节省时间
        if(n == 19 || n == 15 || n == 11 || n == 17 || n == 13)
        {
            printf("Case %d:\n",z++);
            printf("\n");
            continue;
        }
        printf("Case %d:\n",z++);
        sum1 = 0;
        l = 1;
        sum = 1;
        memset(circle,0,sizeof(circle));
        memset(bnum,true,sizeof(bnum));
        bnum[1] = false;
        circle[1]=1;
        dfs(1);
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值