动态规划:HDU1069-Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2618    Accepted Submission(s): 1356


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 


 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

 


 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 


 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 


 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

解题心得:
1、这个题最难的就是找到状态转移方程式,看起来很麻烦,其实不是这样的,状态转移的就只有那么几种,如果发生陌生的动态规划,可以想一下可不可以将这个陌生的动态规划套在一个熟悉的状态转移中。
2、就这个题来说看起来限制很多,其实很简单,盒子是无限多个,所以我们将每一个盒子处理一下,将它按照三种不同的放置方式记录,这个方法是在严格递增的情况下的,只能宽大于宽,长大于长,而不能等于。在处理的时候记录一下长宽高和底面积。这样再按照底面积拍一个序,然后就是一个求最大和。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 500;
struct B
{
    int s;
    int h;
    int w;
    int l;
}box[maxn];
int d[maxn];
int Max = 0;
bool cmp(B a,B b)
{
    return a.s < b.s;
}
int main()
{
    int n;
    int t = 1;
    while(scanf("%d",&n) && n)
    {
        Max = 0;
        memset(d,0,sizeof(d));
        int k = 0;
        for(int i=0;i<n;i++)
        {
            int H,L,W;
            int S;
            scanf("%d%d%d",&H,&L,&W);

            //记录三种不同的放置方式
            S = H*L;
            box[k].s = S;
            box[k].l = L;
            box[k].w = H;
            box[k++].h = W;

            S = L*W;
            box[k].s = S;
            box[k].l = W;
            box[k].w = L;
            box[k++].h = H;

            S = H*W;
            box[k].s = S;
            box[k].l = W;
            box[k].w = H;
            box[k++].h = L;
        }

        sort(box,box+k,cmp);//按照底面积排序
        for(int i=0;i<k;i++)
        {
            d[i] = box[i].h;
            for(int j=0;j<=i;j++)
            {
                if((box[j].l < box[i].l && box[j].w < box[i].w) || (box[j].l < box[i].w && box[j].w < box[i].l))
                {
                    if(d[j] + box[i].h > d[i])
                        d[i] = d[j] + box[i].h;
                }
            }
            if(d[i] > Max)//每次记录一下加起来的最大的和
                Max = d[i];
        }
        printf("Case %d: maximum height = ",t++);
        printf("%d\n",Max);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值