库函数的使用:POJ1488-TEX Quotes(getline()的使用)

TEX Quotes

Time Limit: 1000MS

Memory Limit: 10000K
Total Submissions: 9385

Description

TEX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use double-left-quote and double-right-quote to delimit quotations, rather than the mundane ” which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote and a right-single-quote ‘. Check your keyboard now to locate the left-single-quote key (sometimes called the “backquote key”) and the right-single-quote key ’ (sometimes called the “apostrophe” or just “quote”). Be careful not to confuse the left-single-quote ` with the “backslash” key . TEX lets the user type two left-single-quotes “ to create a left-double-quote and two right-single-quotes ” to create a right-double-quote. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote “.

If the source contained
“To be or not to be,” quoth the bard, “that is the question.”
then the typeset document produced by TEX would not contain the desired form: “To be or not to be,” quoth the bard, “that is the question.” In order to produce the desired form, the source file must contain the sequence:
To be or not to be,” quoth the bard, that is the question.”
You are to write a program which converts text containing double-quote (“) characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TEX for delimiting quotations with oriented double-quotes. The double-quote (“) characters should be replaced appropriately by either if the ” opens a quotation and by ” if the ” closes a quotation. Notice that the question of nested quotations does not arise: The first ” must be replaced by , the next by ”, the next by , the next by ”, the next by “, the next by ”, and so on.

Input

Input will consist of several lines of text containing an even number of double-quote (“) characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that:

the first ” in each pair is replaced by two ` characters: “ and
the second ” in each pair is replaced by two ’ characters: ”.

Sample Input

“To be or not to be,” quoth the Bard, “that
is the question”.
The programming contestant replied: “I must disagree.
To C' or not toC’, that is The Question!”

Sample Output

··To be or not to be,” quoth the Bard, ··that
is the question”.
The programming contestant replied: ··I must disagree.
To ··C’ or not to `C’, that is The Question!”


解题心得:

  1. 题意就是让你将字符串中的英文的双引号改成类似于中文的双引号(并不是中文双引号),很简单,但是要注意一点就是双引号是具有方向的。
  2. 然后就是读入问题,其实可以使用getline来对string类型的进行读入,getline可以读入空格,在遇到回车的时候停止读入,很好用的,读入的格式如下
#include<string>//这个是getline 的头文件
string str;
getline(cin,str);

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5;
string s;
int main()
{
    bool flag = false;
//用来进行左右双引号的区分
    while(getline(cin,s))
    {
        int len = s.length();
        for(int i=0;i<len;i++)
        {
            if(s[i] == '"')
            {
                if(!flag)
                    printf("``");
                else
                    printf("''");
                flag = !flag;
            }
            else
                printf("%c",s[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值