HDU:4632-Palindrome subsequence

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=4632

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65535 K (Java/Others)

Problem Description

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence < A, B, D> is a subsequence of < A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = < Sx1, Sx2, …, Sxk> and Y = < Sy1, Sy2, …, Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input

4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output

Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960


1.这个区间dp状态转移方程推了好久,刚开始的时候只想到由dp[i][j-1]得到,但是实际上是可以有dp[i][j-1]和dp[i+1][j]一同得到,想到了之后又忘记减去dp[i+1][j-1],痛苦啊。
2.其实这个状态转移方程又两部分构成,
- dp[i][j] = dp[i][j-1]+dp[i+1][j] - dp[i+1][j-1];(要减去重合的部分,多加了一次)
- 如果新的字母形成了回文串,dp[i][j] += dp[i+1][j-1] + 1;


#include<bits/stdc++.h>
using namespace std;
const int maxn = 1010;
const int MOD = 10007;
char s[maxn];
int dp[maxn][maxn];

void get_ans()
{
    memset(dp,0,sizeof(dp));
    int len = strlen(s);
    for(int i=0;i<len;i++)
        dp[i][i] = 1;
    for(int i=0;i<len;i++)
    {
        for(int j=0,k=i;k<len;k++,j++)
        {
            dp[j][k] = (dp[j][k-1] + dp[j+1][k] - dp[j+1][k-1] + MOD) % MOD;
            if(s[j] == s[k])
                dp[j][k] += dp[j+1][k-1] + 1;
            dp[j][k] %= MOD;
        }
    }
    printf("%d\n",dp[0][len-1]);
}

int main()
{
    int t;
    cin>>t;
    int cas = 0;
    while(t--)
    {
        scanf("%s",s);
        printf("Case %d: ",++cas);
        get_ans();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值