POJ:3617-Best Cow Line(贪心)

Best Cow Line

Time Limit: 1000MS
Memory Limit: 65536K

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual”Farmer of the Year” competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input
  • Line 1: A single integer: N
  • Lines 2..N+1: Line i+1 contains a single initial (‘A’..’Z’) of the cow in the ith position in the original line
Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’..’Z’) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD


解题

  1. 其实是一个很简单的贪心,就是要你每次将原串从首字母或尾字母放一个到空串的末尾,要求空串最后组成的字符串要字典序最小。
  2. 看起来是每次放到末尾,其实先放到末尾在之后就会挪移前面去。所以,只要每次在首尾选一个更小的字母就行了,但是有一个小小的坑点就是如果首尾字母相同的情况下,要向字符串的中间继续比较,要选一个更小的字母那一方,因为我们需要更早的取到更小的字母。说的很乱,其实就是贪心,尽量让小的字母先出来就行了。

大神的代码

#include <stdio.h>
#include <cstring>
using namespace std;
const int maxn = 2010;
char s[maxn];

int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        char temp[3];
        scanf("%s",temp);
        s[i] = temp[0];
    }

    int l = 0,r = n - 1,cnt = 0;
    while(l <= r){
        bool left;
        left = false;
        for(int i=0;i+l<=r;i++) {
            if(s[i+l] < s[r-i]){
                left = true;
                break;
            }
            if(s[i+l] > s[r-i]){
                left = false;
                break;
            }
        }

        cnt++;
        if(left) putchar(s[l++]);
        else putchar(s[r--]);
        if(cnt%80 == 0)
            putchar('\n');
    }
    return 0;
}

#include <stdio.h>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 2010;
char s[maxn],ans[maxn];
int n;

int main(){
    scanf("%d",&n);
    char temp[3];
    for(int i=0;i<n;i++){
        scanf("%s",temp);
        s[i] = temp[0];
    }

    int l = 0,r = n-1;
    for(int i=0;i<n;i++){
        if(l == r){
            ans[i] = s[l];
            continue;
        }
        if(s[l] == s[r]){//首尾相同继续比较
            int R = r,L = l;
            while(s[R] == s[L] && L<R){
                R--;
                L++;
            }
            if(s[R] < s[L]){
                ans[i] = s[r];
                r--;
            }
            else{
                ans[i] = s[l];
                l++;
            }
        }
        else if(s[l] < s[r]){
            ans[i] = s[l];
            l++;
        }
        else if(s[l] > s[r]){
            ans[i] = s[r];
            r--;
        }
    }

    for(int i=0;i<n;i++){
        cout<<ans[i];
        if((i+1)%80 == 0)
            cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值