HDOJ:2899-Strange fuction

Strange fuction

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11079 Accepted Submission(s): 7407

Problem Description

Now, here is a fuction:
F(x) = 6x7+8x6+7x3+5x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534


解题思路:
  • 这个函数单调性不明确,可以先对这个函数求导,42x6+48x5+21x2+10x-y,一看导数就知道是一个单调递增函数,但是零点不确定,所以在给定y之后可以二分查找零点,然后原函数带入零点得到最小值。
  • 第二个方法就是求导看出是一个单峰函数之后直接三分。

三分答案
#include <bits/stdc++.h>
using namespace std;
const int maxn = 0;

double pow(double a, int b) {
    double ans = 1;
    for(int i=1;i<=b;i++) {
        ans *= a;
    }
    return ans;
}

bool checke(double m1, double m2, double y) {
    double ans1 = m1 * (6.0 * pow(m1, 6) + 8.0 * pow(m1, 5) + 7.0 * pow(m1, 2) + 5.0 * m1 - y);
    double ans2 = m2 * (6.0 * pow(m2, 6) + 8.0 * pow(m2, 5) + 7.0 * pow(m2, 2) + 5.0 * m2 - y);

    if(ans1 < ans2) return false;
    return true;
}

int main() {
//    freopen("1.in", "r", stdin);
    int t; scanf("%d", &t);
    while(t--) {
        double y;
        scanf("%lf", &y);
        double l = 0, r = 100;
        for (int i=1;i<60;i++) {
            double m1 = l + (r - l) / 3;
            double m2 = r - (r - l) / 3;

            if(checke(m1, m2, y))
                l = m1;
            else
                r = m2;
        }

        double ans = l * (6.0 * pow(l, 6) + 8.0 * pow(l, 5) + 7.0 * pow(l, 2) + 5.0 * l - y);
        printf("%.4f\n", ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值