MOOC数据结构 浙江大学 第一周 课后练习2:算法 Maximum Subsequence Sum

算法 Maximum Subsequence Sum 2004年浙江大学计算机专业考研复试真题

题目:Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

给定一个K整数序列{ N1,N2,…,Nk }。连续子序列定义为{ Ni,Ni+1,…,Nj },其中1≤i≤j≤K。最大子序列是具有最大元素和的连续子序列。例如,给定序列{-2,11,-4,13,-5,-2},其最大子序列为{11,-4,13},最大和为20。

现在您应该找到最大和,以及最大子序列的第一个和最后一个数。

输入规格:

每个输入文件包含一个测试用例。每个案件都有两行。第一行包含正整数K(≤10000)。第二行包含K个数字,用空格隔开。

输出规格:

对于每个测试用例,在一行中输出最大和,以及最大子序列的第一个和最后一个数字。数字必须用一个空格隔开,但行尾不能有多余的空格。如果最大子序列不唯一,则输出索引i和j最小的子序列(如示例所示)。如果所有K个数都是负数,那么它的最大和被定义为0,你应该输出整个序列的第一个和最后一个数。

答:在线处理算法

#include<stdio.h>
#define maxmath 50

void maxlist(int num,int *a)
{
	int sum=0,max=0,nmax=0,nmin=0;//sum子列和,max最大子列和,nmax最后一个数 nmin第一个数 
	for(int i=0;i<num;i++)
	{
		sum+=a[i];
		if(sum>max)
		{
			max=sum;
			nmax=i;
		}
		if(sum<0)
		{
			sum=0;
			nmin=i+1;
		}
	}
	printf("%d %d %d",max,a[nmin],a[nmax]);
}

int main()
{
	int a[maxmath];
	int num;//录入num个数 
	void maxlist(int num,int *a);
	scanf("%d",&num);
	for(int i=0;i<num;i++)
	{
		scanf("%d",&a[i]);
	}
	maxlist(num,a);
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值