01-复杂度2 Maximum Subsequence Sum

问题描述

Given a sequence of K integer{ N 1 N_1 N1, N 2 N_2 N2, …, N K N_K NK}. A continuous subsequence is defined to be { N ​ i N_​i Ni, N ​ i + 1 N_{​i+1} Ni+1, …, N j N_j Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

输入格式

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

输出格式

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

输入样例

10
-10 1 2 3 4 -5 -23 3 7 -21

输出样例

10 1 4

解题思路

给一个包含K个整数的数列,求最大子列,找到最大值,并给出该子列的第一个和最后一个元素 。当子列的值相等时,选取i和j之和最小的子列,如果数列中都为负数,则输出0并输出整个数列的第一个元素和最后一个元素
sum为要求的最大和,temp为临时子列和,templeft和tempright为所求最大子列的下标,tempindex为left的临时下标

#include<cstdio>
#include<vector>
#include<iostream>
using namespace std;
int main()
{
	int K;
	cin>>K;
	vector<int> v(K);
	int leftindex = 0, rightindex = K-1, sum = -1, temp = 0, templeft = 0;
	for(int i = 0; i < K; i++){
		cin>>v[i];
		temp += v[i];
		if(temp < 0){
			temp = 0; //舍弃当前子列
			templeft = i+1; //临时左下标直接从i+1开始标记 
		}else if(temp > sum){
			sum = temp;
			leftindex = templeft;
			rightindex = i;
		}
	}
	if(sum < 0)
		printf("0 %d %d\n", v[0], v[K-1]);
	else
		printf("%d %d %d\n", sum, v[leftindex], v[rightindex]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值