ACM 1001题 Sum Problem(为什么你用等差数列会错误)

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 534617    Accepted Submission(s): 135951



Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
 
 
1100
 
Sample Output
 
 
15050
 

Author
DOOM III



题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1001

用等差数列求解的时候,不要用int,因为n(n-1)的数据范围超出了int的数据范围。

  • formula
import java.util.*;

public class Main extends Object {

	private static final Scanner cache = new Scanner(System.in);

	public static void main(String[] args) {

		while (cache.hasNext()) {
			long number = cache.nextLong();
			long SUM = 0;//注意,求和时,不要用int,因为在执行的过程中,计算的值会超过int
			SUM = number + number * (number - 1) / 2;
			System.out.println(SUM);
			System.out.println();
		}

	}

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值