HDU-3351

Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
  
  
}{ {}{}{} {{{} ---
 

Sample Output
  
  
1. 2 2. 0 3. 1



解题思路:这题和这周做的一个题目(类似),但是根据输出的最后一组数据,他所要进行的操作数是1,所以可以推测出题目的大致意思是:给你一些花括号,要你判断那些花括号是合法的,并且如果这些花括号不合法,要让他变得合法,怎样变呢?! 如果给出的括号除去和合法的括号是偶数的话就反转他,是奇数的话先反转在加括号。然而对于不合法的括号只有: }{相反方向和{  {  {  相同方向或者是两种的组合,所以对于开口相同的括号只需要反转一次,不同的就要反转两次,对于奇数的话则要再加一个括号


所以原代码如下:

#include <iostream>
#include <cstdio>
#include <stack>

using namespace std;
typedef long long int LL;
int main()
{
    int kase=1;
    string str;
    while (getline(cin,str))
    {
            if (str[0]=='-')
                break;

            int i;
            stack<char> s;
            int L=str.size();
            s.push('0');
            for (i=0;i<L;i++)
            {
                if (str[i]=='{')
                    {
                        s.push(str[i]);
                    }
                else
                {
                    if (s.top()=='{')
                    {
                        s.pop();
                    }
                    else
                    {
                        s.push(str[i]);
                    }

                }
            }
          //  cout<<s.top()<<endl;
            int num=0;
            for (;;)
            {
                if (s.top()=='0')
                    break;
                else
                {
                    char t;
                    t=s.top();
                    s.pop();
                    if (s.top()!='0' &&t==s.top())
                    {
                        num++;
                        s.pop();
                    }
                    else if (s.top()!='0' &&t!=s.top())
                    {
                        num+=2;
                        s.pop();
                    }
                    else
                    {

                        num++;
                    }

                }
            }
            printf("%d. %d\n",kase,num);
            kase++;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值