描述
Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.
输入
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.
输出
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:
Case 1: the next triple peak occurs in 1234 days.
Use the plural form ``days'' even if the answer is 1.
样例输入
0 0 0 0 0 0 0 100 5 20 34 325 4 5 6 7 283 102 23 320 203 301 203 40 -1 -1 -1 -1
样例输出
Case 1: the next triple peak occurs in 21252 days. Case 2: the next triple peak occurs in 11252 days. Case 3: the next triple peak occurs in 19575 days. Case 4: the next triple peak occurs in 16994 days. Case 5: the next triple peak occurs in 8910 days. Case 6: the next triple peak occurs in 10789 days.
中文大意:人有三个循环周期:身体、情感、心理;周期长度分别为23,28,33。每个周期的峰值时间也不同;
给出p,e,i即当前年初到身体、情感、心理峰值的天数(不一定是第一个),d是从年初到给定日期的天数;计算从给定日期到下个三峰天数; 若给定日期为10,下个三峰在12,结果为2;三峰就在给定日期,结果为给定日期到下个三峰的天数。假设在给定日期的21252天内将出现三峰值。输入的结束由一条线表示,其中p = e = i = d = -1。
AC代码
#include <cstdio>
#include <cmath>
int main(){
int p,e,i,d;
int n=0;
while(scanf("%d%d%d%d",&p,&e,&i,&d)==4){
if(p==-1)break;
n++;
int day=d+1;
while(1){
if((day-p)%23==0&&(day-e)%28==0&&(day-i)%33==0)
{printf("Case %d: the next triple peak occurs in %d days.\n",n,day-d);break;}
else
day++;
}
}
}