百炼1008:Maya Calendar

描述

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . Years (both Haab and Tzolkin) were denoted by numbers 0, 1, . . . , where the number 0 was the beginning of the world. Thus, the first day was: Haab: 0. pop 0 Tzolkin: 1 imix 0 Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

输入

The date in Haab is given in the following format:
NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

输出

The date in Tzolkin should be in the following format:
Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

样例输入

3
10. zac 0
0. pop 0
10. zac 1995

样例输出

3
3 chuen 0
1 imix 0
9 cimi 2801

中文大意:Haab日历->Tzolkin日历

 Haab:19个月

        前18个月均有20天:pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu

        最后一个月uayet有5天

        一年365=18*20+5

        日历形式:天(0-19)月(月名)年(数字)

Tzolkin :分13个周期,每周期20天,每天用1个数字(1-13)和当天的名字表示

              20天的名字:imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau

从世界第一天1 minx 0开始,二十天一个周期

1 imix,2  ik,3  akbal,4  kan, 5 chicchan, 6 cimi,7  manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac,7  ahau

下个周期从8 imix开始

13个周期过了就是一年

AC代码:

#include <cstdio>
#include <cstring>
int find_md(char s1[],char s2[19][7]){
	int i;
	for(i=0;i<19;i++){
		if(strcmp(s1,s2[i])==0)
		   return i*20;
	}
}
int main(){
	int n,hd,hy,day;
	char td[20][9]={"imix","ik","akbal","kan","chicchan","cimi",
           	    "manik","lamat","muluk","ok","chuen","eb","ben", 
	            "ix","mem","cib","caban","eznab","canac","ahau"};
	char hm[19][7]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen", "yax", 
	           "zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
	char s[7];
	scanf("%d",&n);
	printf("%d\n",n);
	for(int i=0;i<n;i++){
		scanf("%d. %s %d",&hd,s,&hy);
		day=hd+find_md(s,hm)+hy*365;
		printf("%d %s %d\n",day%13+1,td[day%20],day/260);
	}
}

注意:

 二维数组做函数形参,一定要给出列数   void func(char a[][4])

string.h中的strcmp()函数比较两字符串的内容是否相同,相同返回0,不同返回非零

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值