[kuangbin带你飞]专题二 搜索进阶 A(康拓展开+bfs)

A - Eight

The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:

1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x

where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->

The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,’l’,’u’ and ‘d’, for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word “unsolvable”, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
2 3 4 1 5 x 7 6 8
Sample Output
ullddrurdllurdruldr

#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<map>
#include<cstdio>
using namespace std;
const int maxn=362890;
const int INF=0x3f3f3f3f;
struct Node {
    int hashs;
    int local;
    int s[9];
};


bool book[maxn];
vector<char> path[maxn];
int fac[]={1,1,2,6,24,120,720,5040,40320,362880};
int cnt[4][2]={1,0,-1,0,0,1,0,-1};
char xcnt[5]={'u','d','l','r'};

int cantor(int s[]) {
    int sum=0;
    for(int i=0;i<9;i++) {
            int num=0;
        for(int j=i+1;j<9;j++) {
            if(s[j]<s[i])num++;
        }
        sum+=(num*fac[8-i]);
    }
    return sum+1;
}

void bfs() {
    memset(book,false,sizeof(book));
    Node now,next;
    now.hashs=46234;
    now.local=8;
    for(int i=0;i<8;i++) now.s[i]=i+1;
    now.s[8]=0;
    book[now.hashs]=true;
    queue<Node> Q;
    while(!Q.empty())Q.pop();
    Q.push(now);
    while(!Q.empty()) {
        now=Q.front();
        Q.pop();
        int x=now.local/3,y=now.local%3;
        for(int i=0;i<4;i++) {
            int dx=x+cnt[i][0],dy=y+cnt[i][1];
            if(dx>2||dx<0||dy>2||dy<0) continue;
            next=now;
            next.local=dx*3+dy;
            next.s[now.local]=next.s[next.local];
            next.s[next.local]=0;
            next.hashs=cantor(next.s);
            if(book[next.hashs]==false) {
                book[next.hashs]=true;
                Q.push(next);
                path[next.hashs]=path[now.hashs];
                path[next.hashs].push_back(xcnt[i]);
            }
        }
    }
    return ;
}

int main()
{
    bfs();
    char x;
    Node now;
    while(cin>>x) {
        if(x=='x') {now.s[0]=0;now.local=0;}
        else now.s[0]=x-'0';
        for(int i=1;i<=8;i++) {
            cin>>x;
            if(x=='x') {now.s[i]=0;now.local=i;}
            else now.s[i]=x-'0';
        }
        now.hashs=cantor(now.s);
        if(now.hashs==46234) cout<<"lr"<<endl;
        else if(book[now.hashs]==true) {
            for(int i=path[now.hashs].size()-1;i>=0;i--) {
                cout<<path[now.hashs][i];
            }
            cout<<endl;
        }
        else cout<<"unsolvable"<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值