[kuangbin带你飞]专题二 搜索进阶 E

The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.
这里写图片描述
For example, given “ACGT”,”ATGC”,”CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
Sample Input
1
4
ACGT
ATGC
CGTT
CAGT
Sample Output
8

这道题是对退出DFS的判断问题,首先要判断一下最长的有多长,然后当
这个节点对所有的DNA都没有贡献时就退出,这里用到了迭代加深搜索,就是我每一次搜索都指定一个最大搜索长度,如果大于这个搜索长度就退出,然后再深入一层,防止无限次的加深搜索

#include<bits/stdc++.h>
using namespace std;
#define bug cout<<"This is a BUG!"<<endl;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int n,deep,ans=-1;
char s[10][10];
int size[10];

char cnt[5]={'A','T','C','G'};

void dfs(int num,int len[]) {
    int sum=0;
    if(ans!=-1||num>deep) return;
    for(int i=0;i<n;i++) sum=max(sum,size[i]-len[i]);
    if(num+sum>deep) return ;
    if(sum==0) {ans=num;return ;}
    for(int i=0;i<4;i++) {
        int flag=0;
        int tlen[10]={0};
        for(int j=0;j<n;j++) {
            if(s[j][len[j]]==cnt[i]) {
                tlen[j]=len[j]+1;
                flag++;
            }
            else tlen[j]=len[j];
        }
        if(flag>0)
        dfs(num+1,tlen);
    }
    return ;
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int T;
    cin>>T;
    for(int k=0;k<T;k++) {
        ans=-1,deep=0;
        cin>>n;
        memset(s,0,sizeof(s));
        for(int i=0;i<n;i++) {
            cin>>s[i];
            size[i]=strlen(s[i]);
            deep=max(deep,size[i]);
        }
        int len[10]={0};
        while(1) {
            dfs(0,len);
            if(ans!=-1) break;
            deep++;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值