Employment Planning
Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single ‘0’.
Output
The output contains one line. The minimal total cost of the project.
Sample Input
3
4 5 6
10 9 11
0
Sample Output
199
这道题就是给你雇佣一个工人需要的钱,工人每月的工资,解雇工人需要的钱,然后给你最多12个月每个月需要的钱,然后问题最少花费是多少
这道题用DP或贪心都可以,而且不需要什么优化技巧,暴力就行,我们每个月的底线是上一个月的最少人数开始,递推就好了,而且测试数据不是很大,好像人数最多是105
#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int dp[20][100000];
int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
int n;
while(cin>>n&&n) {
int salary,fire,hire,month[20]={0},maxn=0,sum=INF;
cin>>hire>>salary>>fire;
for(int i=1;i<=n;i++) {cin>>month[i];maxn=max(maxn,month[i]);}
for(int i=1;i<=n;i++) {
for(int j=0;j<=maxn;j++) {
dp[i][j]=INF;
}
}
for(int i=month[1];i<=maxn;i++) dp[1][i]=(hire+salary)*i;
for(int i=2;i<=n;i++){
for(int j=month[i];j<=maxn;j++) {
for(int k=month[i-1];k<=maxn;k++){
if(k<=j) dp[i][j]=min(dp[i][j],dp[i-1][k]+(j-k)*(hire+salary)+k*salary);
else dp[i][j]=min(dp[i][j],dp[i-1][k]+(k-j)*fire+j*salary);
}
}
}
for(int i=month[n];i<=maxn;i++) sum=min(sum,dp[n][i]);
cout<<sum<<endl;
}
return 0;
}