Shortest Proper Prefix

Shortest Proper Prefix

题目

Query auto-completion(QAC) is widely used in many search applications. The basic idea is that when you type some string s in the search box several high-frequency queries which have s as a prefix are suggested. We say string s1 has string s2 as a prefix if and only if the first |s2| characters of s1 are the same as s2 where |s2| is the length of s2.

These days Little Hi has been working on a way to improve the QAC performance. He collected N high-frequency queries. We say a string s is a proper prefix if there are no more than 5 collected queries have s as a prefix. A string s is a shortest proper prefix if s is a proper prefix and all the prefixes of s(except for s itself) are not proper prefixes. Little Hi wants to know the number of shortest proper prefixes given N collected queries.

Hint: the 4 shortest proper prefixes for Sample Input are “ab”, “bb”, “bc” and “be”. Empty string “” is not counted as a proper prefix even if N <= 5.

输入

The first line contains N(N <= 10000), the number of collected queries.

The following N lines each contain a query.

Each query contains only lowercase letters ‘a’-‘z’.

The total length of all queries are no more than 2000000.

Input may contain identical queries. Count them separately when you calculate the number of queries that have some string as a prefix.

输出

Output the number of shortest proper prefixes.

样例输入

12
a
ab
abc
abcde
abcde
abcba
bcd
bcde
bcbbd
bcac
bee
bbb

样例输出

4

思路:

使用字典树的方法来实现。先构造带访问次数的字典树,然后在遍历查找有多少个访问次数小于5的前缀。

代码:

import java.util.*;

class TreeNode{
    int val = 0;
    char ch;
    TreeNode[] child;
    TreeNode(){
        child = new TreeNode[26];
    }

    public void insert(TreeNode root, String str){
        TreeNode p = root;
        p.val++;
        char[] cstr = str.toCharArray();
        for(int i = 0; i < str.length(); i++){
            int idx = cstr[i] - 'a';
            if(p.child[idx] == null)
                p.child[idx] = new TreeNode();
            p = p.child[idx];
            p.ch = cstr[i];
            p.val++;
        }
    }

}
public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            String ns = sc.nextLine();
            int n = Integer.parseInt(ns);
            String[] sin = new String[n];
            TreeNode root = new TreeNode();
            for(int i = 0; i < n; i++){
                sin[i] = sc.nextLine();
                root.insert(root, sin[i]);
            }
            find(root);
            System.out.println(result);
        }
        sc.close();
    }
    public static int result = 0;
    public static void find(TreeNode p){
        if(p.val <= 5){
            result++;
            return;
        }   
        for(int i = 0; i < 26; i++){
            if(p.child[i] != null && p.child[i].val > 5)
                find(p.child[i]);   
            if(p.child[i] != null && p.child[i].val <= 5)
                result++;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值