ASCII码排序
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 55982 Accepted Submission(s): 22977
Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe asd zxc
Sample Output
e q w a d s c x z
Author
lcy
Source
Recommend
JGShining
#include <iostream>
using namespace std;
void sortChar(char a[],int n)
{
for (int i = 0;i < n; i++)
for (int j = i+1; j < n; j++)
{
if(a[i] > a[j])
{
char temp = a[i];
a[i] = a[j];
a[j] = temp;
}
}
}
int main()
{
char a[3];
while(cin>>a)
{
sortChar(a,strlen(a));
for (int j = 0; j < strlen(a); j++) {
cout<<a[j];
if(j != strlen(a)-1)
cout<<" ";
}
cout<<endl;
}
return 0;
}