hdu 2053

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7656    Accepted Submission(s): 4528


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL
 

Source
 

Recommend
linle
 
//对于编号1,只反方向拨了一次,所以是关熄状态;
//对于编号2,1的倍数反拨一次,2的倍数又拨一次,此后就不再拨动了,所以是开状态;
//对于编号3,1的倍数反拨一次,3的倍数又拨一次,此后就不再拨动了,所以是开状态;
//对于编号4,1的倍数反拨一次,2的倍数又拨一次,4的倍数又拨一次,此后就不再拨动了,所以是关熄状态;。。。
//
//所有的质数只有1和质数本身两个公约数,所以,一定会被拨动两次,最后的状态一定是开;
//所有的合数,除了是某个数的平方数外,其公约数个数一定是成对出现的,如32,其公约数为1,2,4,8,16,32,
//再如84,其公约数为1,2,4,6,7,12,14,21,42,84,为偶数,即1和84,2和42,4和21,6和14,7和12,都是成对出现的,
//所有一定会被拨动偶数次,最后的状态也一定为开。
//
//只有平方数,其公约数一定为奇数个,如36,其公约数为1,2,3,4,6,9,12,18,36,中间的6是不配对的,所以一定为奇数个,
//所以一定会被拨动奇数次,最后的状态一定为关熄状态。
#include <stdio.h>
#include <math.h>
int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		printf(sqrt(n)*sqrt(n) == n ? "1\n" : "0\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值