hdu 4150 Powerful Incantation 暴力||KMP

Powerful Incantation

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1644    Accepted Submission(s): 732


Problem Description
Some dangerous Witches invaded the garden city! As a righteous magician, james0zan want to find the most powerful incantation so he can beat those dangerous witches easily.
After consulted one hundred and eight thousand Magic Books, james0zan find a way to calculate the power of an incantation. There is a very short incantation called “magic index” which contains the magic power, and each incantation’s power can be calculated by the times the “magic index” appearance in the incantation. Notice that if two “magic index” overlapped, the power only should be calculated once. And we just want the incantation more powerful. That is to say, if the “magic index” is “aa”, the power of incantation “aaaa” is 2(“aa”+”aa”), not 1(“a”+”aa”+”a”) or 3.
 

Input
The first line is an integer t (t<=30), the number of test cases. Each of the next t lines contains two strings, represent the incantation (length<=10^6) and the “magic index” (length<=5). Every char in the incantation and the magic index is lowercase.
 

Output
For each test case you should output the power of the incantation.
 

Sample Input
  
  
3 aaaa aa bsdjfassdiifo sd papapapapapapap ap
 

Sample Output
  
  
2 2 7
 

Author
BUPT
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4149  4152  4151  4148  4144 


就是这个题,超级水题,看着别人队都做出来了,然而我学的KMP又麻烦,又怪异,不知道哪wa了,
折腾了一个半小时,结果还是队友用kuangbin模板A掉了。 哭时间都被耽误了。
终于又学了套新的KMP写法:

char x[1000000+10],y[8];

int nex[10],n,m;
void pre()
{
    int j=nex[0]=-1,i=0;
    while(i<m)
    {
        while(j!=-1&&y[i]!=y[j])  j=nex[j];
        nex[++i]=++j;
    }
}

int  KMP()
{
    int i=0,j=0,ans=0;
    while(i<n)
    {
        while(j!=-1&&x[i]!=y[j])  j=nex[j];
        i++;j++;
        if(j>=m)
        {
            ans++;
            j=0;
        }
    }


    return ans;
}
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",x,y);
        n=strlen(x);
        m=strlen(y);
        pre();
        printf("%d\n",KMP() );
    }


    return 0;
}

 
头文件:

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second

using namespace std;
const int INF =0x3f3f3f3f;
//const int maxn=    ;
//const int maxm=    ;
//const int INF=    ;
typedef long long ll;
const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
//by yskysker123


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值