poj 2392 Space Elevator 排序(贪心)+多重背包 仍然很水 ★★

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9955 Accepted: 4731

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source



按照最大高度将物品从小到大排序,之后根据这个顺序进行DP。


实际上还是有些东西值得思考的,我看了题目就感觉要升序排列。


这之中深层的原因是,对于我们分阶段进行的动归,前面的阶段在前,后面的阶段在后,也就是说

每次转移,都是对这个状态最后的某段在进行改变。

实际的物品排列应该是限制高度较小的在前面放,然后才是限制高度较高的在后放,

这其实是个贪心,也就是说这个题目是贪心+dp。


举个例子,假如说先考虑,h = 4 ,limit 9,再考虑h =4  ,limit 5,则第一步从v=0~9,第二步0~5,  最终答案是h=4。

如果先考虑h =4  ,limit 5,再考虑h = 4 ,limit 9,则结果是9,

第一种顺序是错误的,因为进行了这么两阶段的动归,实质上永远是把物品1放在物品2下面去了,当然是不对的。





#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   ind<<1,le,mid
#define rson    ind<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 400+20    ;
const int maxV= 40000+20    ;
int n,V;
struct BAG
{
    int val;
    int limit;
    int num;
    bool operator<(const BAG &y)const
    {
        return  limit<y.limit;
    }
}  bag[ maxn];

bool dp[maxV];
int main()
{
    while(~scanf("%d",&n))
    {
      for(int i=1;i<=n;i++)
      {
          scanf("%d%d%d",&bag[i].val,&bag[i].limit,&bag[i].num);
      }
      memset(dp,0,sizeof dp);
      dp[0]=1;
      sort(bag+1,bag+1+n);
      for(int i=1;i<=n;i++)
      {

          V=bag[i].limit;
          int tot=bag[i].num;
          for(int cnt=1;cnt<=tot ; tot-=cnt  ,cnt*=2)
          {
              int cost=cnt*bag[i].val;
              for(int v=V;v>=cost;v--)
              {
                  dp[v]=dp[v-cost]|dp[v];
              }

          }
          if(!tot)  continue;
          int cost=tot*bag[i].val;
          for(int v=V;v>=cost;v--)
          {
              dp[v]=dp[v-cost]|dp[v];
          }



      }

      for(int v=bag[n].limit;v>=0;v--)
      {
          if(!dp[v])  continue;
          printf("%d\n",v);
          break;
      }
    }


    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值