poj 3252 Round Numbers 二进制+组合

题意:

输入两个十进制正整数ab,求闭区间 [a ,b] 内有多少个Round number

所谓的Round Number就是把一个十进制数转换为一个无符号二进制数,若该二进制数中0的个数大于等于1的个数,则它就是一个Round Number


题解


Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11653 Accepted: 4380

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source



#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<iomanip>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define ysk(x) (1(ll)<<(x))
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn=34    ;
int le,ri;
int bin[40];//存放一个数的二进制编码,bin[0]表示长度,bin[1]表示最低位的二进制编码
ll ans,C[maxn][maxn];
void pre(int x)
{
    bin[0]=0;
    while(x)
    {
        bin[++bin[0]]=x%2;
        x/=2;
    }

}
ll cal(int x)
{
    if(!x) return 0;//这种按位处理和进制转换的题目,特别小心0的情况。
    ll ret=0;
    pre(x);
    for(int len=1;len<bin[0]-1;len++)//除去最高位的1,可用位数为len
    {
        int zero_least=(len+2)/2;//0至少要出现的次数
        for(int num=zero_least;num<=len;num++)
        {
            ret+=C[len][num];
        }
    }

    int zero_num=0;
    for(int p=bin[0]-1;p>=1;p--)
    {
        if(!bin[p])
        {
            zero_num++;
        }
        else
        {
            int zero_least= (bin[0]+1)/2 -zero_num-1 ;
            zero_least=max(0,zero_least);
            for(int num=zero_least;num<=p-1;num++)
            {
                ret+=C[p-1][num];
            }
        }
    }
    if(zero_num>= (bin[0]+1)/2 )  ret++;
    return ret;

}

void getC()
{
    C[0][0]=1;
    for(int i=1;i<=maxn;i++)
    {
        C[i][0]=C[i][i]=1;
        for(int j=1;j<i;j++)
        {
            C[i][j]=C[i-1][j-1]+C[i-1][j];
        }
    }

}
int main()
{
    getC();
    scanf("%lld%lld",&le,&ri);

    ans=cal(ri)-cal(le-1);
    printf("%lld\n",ans);

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值