poj 2661 Factstone Benchmark 取对数


题目

简化版问题:

给定n ,求最大的k,使得
2^(4*2^(n)   )> k!   (n<=20)




两边取对数

pow(2,n+2)>log2(k)+log2(k-1)+...+log2(1);

Factstone Benchmark
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4162 Accepted: 2064

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.) 
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word. 
Given a year 1960 <= y <= 2160, what will be the Factstone rating of Amtel's most recently released chip?

Input

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

Source


G++

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn= 20   ;
const int st=1960;
int n;
/*
给定n ,求最大的k,使得
2^(4*2^(n)   )> k!
两边取对数
得
pow(2,n+2)>log2(k)+log2(k-1)+...+log2(1);
*/
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        n=(n-st)/10;
        double t=pow(2,2+n);
        int ans=1;double s=0;
        while(s+log2(ans+1)<t)
        {
            s=s+log2(ans+1);
            ans++;
        }
        printf("%d\n",ans);
    }

   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值