hdu 5512 Pagodas gcd()


Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1137    Accepted Submission(s): 808


Problem Description
n  pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from  1  to  n . However, only two of them (labelled  a and  b , where  1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled  i (i{a,b} and 1in)  if there exist two pagodas standing erect, labelled  j  and  k  respectively, such that  i=j+k  or  i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer  t (1t500)  which is the number of test cases.
For each test case, the first line provides the positive integer  n (2n20000)  and two different integers  a  and  b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
  
  
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
  
  
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928 
 

Statistic |  Submit |  Discuss |  Note


以前好像做过,不过当时不是队友做的,就是瞎搞的,反正应该没弄清楚。


现在的思路是:

首先要确定区间内的数有多少个可以选,判断是奇数还是偶数,奇数Yuwgna胜,偶数Iaka

给我的感觉是不断相减(辗转相除)找到最小的量,


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
int n;

int cal(int a,int b)
{
    if(b==0)  return a;
    return cal(b,a%b);
}
int main()
{
   std::ios::sync_with_stdio(false);
   int a,b,T,kase=0;cin>>T;
   while(T--)
   {
       cin>>n>>a>>b;
       if(a>b) swap(a,b);
       int p=cal(b,a);
       int num=   (a-1)/p+ (b-a)/p+1+ (n-b)/p;
       printf("Case #%d: ",++kase);
       puts(num&1?"Yuwgna":"Iaka");
   }
   return 0;
}





代码修改后:


看了别人的代码后,直接n/p即可,因为p就是求gcd(a,b)。

两个操作 a+b和b-a,都有gcd|a+b,gcd|b-a,所以不管加减操作多少次都是gcd的倍数。

所以就是要求[1,n]内有多少个数是gcd的倍数。


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
int n;

int cal(int a,int b)
{
    return b==0?a:cal(b,a%b);
}
int main()
{
   std::ios::sync_with_stdio(false);
   int a,b,T,kase=0;cin>>T;
   while(T--)
   {
       cin>>n>>a>>b;
       int p=cal(a,b);
       int num=   n/p;
       printf("Case #%d: ",++kase);
       puts(num&1?"Yuwgna":"Iaka");
   }
   return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值