题目:
1833: [ZJOI2010]count 数字计数
Time Limit: 3 Sec Memory Limit: 64 MBSubmit: 2853 Solved: 1266
[ Submit][ Status][ Discuss]
Description
给定两个正整数a和b,求在[a,b]中的所有整数中,每个数码(digit)各出现了多少次。
Input
输入文件中仅包含一行两个整数a、b,含义如上所述。
Output
输出文件中包含一行10个整数,分别表示0-9在[a,b]中出现了多少次。
Sample Input
1 99
Sample Output
9 20 20 20 20 20 20 20 20 20
HINT
30%的数据中,a<=b<=10^6;
100%的数据中,a<=b<=10^12。
Source
解法:
1.状态设计
struct DP
{
ll dgt[10],sum;
DP() { mem(dgt,0); }
DP(ll sum):sum(sum) { mem(dgt,0); }
}dp[20][2],ans[2];
dp[len][1]表示长度为len的数,且具有前导零的状态,
其中的dgt[1...10]分别表示数字[1...10]出现了多少次。
sum表示种数,即有多少个数。
2.状态转移
DP dfs(int pos,int lead,int limit)
{
if(pos==-1) return DP(1);
if(!limit&&~dp[pos][lead].sum) return dp[pos][lead];
int up=limit?bit[pos]:9;
DP now(0);
for0(i,up+1)//枚举当前位的数字
{
DP t=dfs(pos-1,lead&&!i,limit&&i==bit[pos]);
for0(j,10) now.dgt[j]+=t.dgt[j];//首先要把pos-1的各种情况全部加进来。
now.sum+=t.sum;//sum表示种数
if(!lead||lead&&i) now.dgt[i]+=t.sum;//只有没有前零或者有但是当前位不为0的情况,当前位才算入答案。
}
if(!limit) dp[pos][lead]=now;
return now;
}
注意:有无前导零在本题的状态转移中是比较关键的,需要区别对待,所以我将是否有前导零加入到了状态表示里
3.AC代码
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;
#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s) memset(a,x,(s)*sizeof a[0])
#define mem(a,x) memset(a,x,sizeof a)
#define ysk(x) (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
int bit[20];
struct DP
{
ll dgt[10],sum;
DP() { mem(dgt,0); }
DP(ll sum):sum(sum) { mem(dgt,0); }
}dp[20][2],ans[2];
DP dfs(int pos,int lead,int limit)
{
if(pos==-1) return DP(1);
if(!limit&&~dp[pos][lead].sum) return dp[pos][lead];
int up=limit?bit[pos]:9;
DP now(0);
for0(i,up+1)
{
DP t=dfs(pos-1,lead&&!i,limit&&i==bit[pos]);
for0(j,10) now.dgt[j]+=t.dgt[j];
now.sum+=t.sum;
if(!lead||lead&&i) now.dgt[i]+=t.sum;
}
if(!limit) dp[pos][lead]=now;
return now;
}
void solve(int k,ll x)
{
int nbit=0;
while(x)
{
bit[nbit++]=x%10;
x/=10;
}
ans[k]= dfs(nbit-1,1,1);
}
int main()
{
std::ios::sync_with_stdio(false);
ll a,b;
for0(i,20) for0(j,2) dp[i][j].sum=-1;
while(cin>>a>>b)
{
mem(&ans,0);
solve(1,b);
solve(0,a-1);
for0(i,10) printf("%lld%c",ans[1].dgt[i]-ans[0].dgt[i],i==9?'\n':' ');
}
return 0;
}