1112 Stucked Keyboard(20 分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

思路:

键盘某些键卡住了,按一次重复k次,要求找出可能的键,并且输出正确的字符串顺序。可能的键要求按照被发现的顺序输出。

第一遍写的代码第二个测试点一直不过,很难过想不明白,就换了一版;

C++(第二个测试点不过):

#include "cstdio"
#include "map"
#include "iostream"
#include "string"
using namespace std;
map<string, bool> m;
map<string, bool> sureNoBroken;
string printed[1010];
int main(){
	int k,i=0,cnt=0;//重复k次 遍历i 坏掉的个数
	string str;
	scanf("%d",&k);
	cin>>str;
	str+='#';
	while(i<str.length()){
		string a,temp;
		a=str[i];
		//这个字符没坏
		if (sureNoBroken[a]==true)
		{
			i++;
			continue;
		}
		for (int j=0;j<k;j++)temp+=a;
		//找到第一个重复的字串
		if (str.find(temp,i)==i)
		{
			str.replace(i,k,a);
			if (m[a]==false)
			{
				m[a]=true;
				printed[cnt++]=a;
			}
		}else{
			sureNoBroken[a]=true;
		}
		i++;
	}
	for (int j=0;j<cnt;j++)
		cout<<printed[j];
	printf("\n");
	for (int j=0;j<str.length()-1;j++)
	{
		cout<<str[j];
	}
	return 0;
}

C++(AC版):

#include <iostream>
#include <string>
#include <vector>
using namespace std;
 
int main()
{
	//freopen("in.txt", "r", stdin);
	int K;//按键重复出现的个数
	string str;
	cin >> K >> str;
	str.push_back('A');//加入字符A,为了后面便于遍历。
	int stucked[128] = { 0 };//存储坏的。
	int worked[128] = { 0 };//存储正常的
	vector<char> sv;//用于输出坏的按键。
 
	int cnt = 1;
	int i = 1;
	while (i < str.size())
	{
		while (str[i] == str[i - 1] && i < str.size())//相同的
		{
			cnt++;
			i++;
		}
 
		if (cnt % K == 0 && worked[str[i - 1]] == 0)//重复出现,且不正常
		{
			sv.push_back(str[i - 1]);//压入容器
		}
		else
			worked[str[i - 1]] = 1;//正常的按键
 
		cnt = 1;
		i++;
	}
 
	for (int i = 0; i < sv.size(); i++)//输出坏的
	{
		if (worked[sv[i]] == 0)
		{
			cout << sv[i];
			stucked[sv[i]] = 1;//该按键是坏的。
			worked[sv[i]] = 1;//输出一个之后,置为1,以防后面重复输出。
		}
	}
	cout << endl;
 
	int j = 0;
	while (j < str.size() - 1)//最后一个字符是检验的,不遍历。
	{
		if (stucked[str[j]] == 0)//好的
		{
			cout << str[j];
			j++;
		}
		else
		{
			cout << str[j];//坏的,j前移k个
			j += K;
		}
	}
	
	cout << endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值