1127 ZigZagging on a Tree(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

思路:

给出一个树的中序和后序遍历结果,求它的Z字型层序遍历,也就是偶数层从右往左,奇数层从左往右遍历

C++:

#include "queue"
#include "iostream"
#include "vector"
using namespace std;
vector<int> in, post, result[35];
int n, tree[35][2], root;//tree[x][0]左孩子 tree[x][1]右孩子
struct node
{
	int index,depth;
};
void dfs(int &index,int inLeft,int inRight,int postLeft,int postRight){
	if (inLeft>inRight)return;
	index=postRight;
	int i=0;
	while (in[i]!=post[postRight])i++;
	dfs(tree[index][0],inLeft,i-1,postLeft,postLeft+(i-inLeft)-1);
	dfs(tree[index][1],i+1,inRight,postLeft+(i-inLeft),postRight-1);
}
void bfs() {
	queue<node> q;
	q.push(node{root, 0});
	while (!q.empty()) {
		node temp = q.front();
		q.pop();
		result[temp.depth].push_back(post[temp.index]);
		if (tree[temp.index][0] != 0)
			q.push(node{tree[temp.index][0], temp.depth + 1});
		if (tree[temp.index][1] != 0)
			q.push(node{tree[temp.index][1], temp.depth + 1});
	}
}
int main() {
	cin >> n;
	in.resize(n + 1), post.resize(n + 1);
	for (int i = 1; i <= n; i++) cin >> in[i];
	for (int i = 1; i <= n; i++) cin >> post[i];
	dfs(root, 1, n, 1, n);
	bfs();
	printf("%d", result[0][0]);
	for (int i = 1; i < 35; i++) {
		if (i % 2 == 1) {
			for (int j = 0; j < result[i].size(); j++)
				printf(" %d", result[i][j]);
		} else {
			for (int j = result[i].size() - 1; j >= 0; j--)
				printf(" %d", result[i][j]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值