树形Dp——poj2486 Apple Tree

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2


#include<stdio.h>
int head[101];
int next[201];
int to[201];
int n,v,idx;
int apple[101];
int f[101][201];
int g[101][201];
int max1[201],max2[101];
int max(int a,int b)
{
	if(a>b)
		return a;
	return b;
}
void play(int from,int p)
{
	for(int i=head[p];i;i=next[i])
		if(to[i]!=from)
		{
			play(p,to[i]);
			for(int j=v;j>=1;j--)
			{
				/*‘j从大到小,以防用小的处理大的,如果小的处理大的,会使小的重复计算,叠加,是值变得更大。’*/
				for(int k=2;k<=j;k++)
					f[p][j]=max(f[to[i]][k-2]+f[p][j-k],f[p][j]),g[p][j]=max(f[to[i]][k-2]+g[p][j-k],g[p][j]);
				/*‘k-2:从当前点走到儿子,再走回儿子,所以会减2,再从当前点走j-k步回来和不回来。’*/
				for(int k=1;k<=j;k++)
					g[p][j]=max(g[to[i]][k-1]+f[p][j-k],g[p][j]);
				/*’k-1:从当前点出发走j-k步回来,再走1步,到达儿子,再从儿子走看k-1步不回来‘*/
			}
		}
}
int main()
{
	while(scanf("%d%d",&n,&v)==2)
	{
		idx=0;
		for(int i=1;i<=n;i++)
			scanf("%d",&apple[i]),head[i]=0;
		for(int i=1;i<=n;i++)
			for(int j=0;j<=v;j++)
				f[i][j]=g[i][j]=apple[i];
		for(int i=1;i<n;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			next[++idx]=head[a];
			head[a]=idx;
			to[idx]=b;
			next[++idx]=head[b];
			head[b]=idx;
			to[idx]=a;
		}
		play(0,1);
		printf("%d\n",max(f[1][v],g[1][v]));
	}
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值